initial import
[slovak-l10n] / ukeyboard / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 DESTDIR=$(CURDIR)/debian/ukeyboard
13 DESTDIR_CREATOR=$(CURDIR)/debian/ukbdcreator
14
15 configure: configure-stamp
16 configure-stamp:
17         dh_testdir
18
19         touch configure-stamp
20
21
22 build: build-stamp
23
24 build-stamp: configure-stamp 
25         dh_testdir
26
27 #       for OS2008
28 #       $(MAKE)
29 #       for Maemo5
30         CFLAGS="$(CFLAGS) -DHAVE_MAEMO5" $(MAKE)
31
32         touch build-stamp
33
34 clean:
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp configure-stamp
38
39         # Add here commands to clean up after the build process.
40         $(MAKE) clean
41
42         dh_clean 
43
44 install: build
45         dh_testdir
46         dh_testroot
47         dh_clean -k 
48         dh_installdirs
49
50         # Add here commands to install the package into $(DESTDIR)
51         $(MAKE) DESTDIR=$(DESTDIR) install
52         $(MAKE) -C ukbdcreator DESTDIR=$(DESTDIR_CREATOR)/usr install
53
54
55 # Build architecture-independent files here.
56 binary-indep: build install
57 # We have nothing to do by default.
58
59 # Build architecture-dependent files here.
60 binary-arch: build install
61         dh_testdir
62         dh_testroot
63 #       dh_installchangelogs 
64         dh_fixperms
65         dh_installdeb
66         dh_gencontrol
67         dh_md5sums
68         dh_builddeb
69
70 binary: binary-indep binary-arch
71 .PHONY: build clean binary-indep binary-arch binary install configure