Uses Scratchbox dh_make to generate the package files. debian_helper
authorFelipe Zimmerle <felipe@zimmerle.org>
Tue, 29 Sep 2009 23:21:12 +0000 (20:21 -0300)
committerFelipe Zimmerle <felipe@zimmerle.org>
Tue, 29 Sep 2009 23:21:12 +0000 (20:21 -0300)
Maemo still using the dh_make compatible with debian helper 5.
Dowgrading to make it work with the Scratchbox.

Signed-off-by: Felipe Zimmerle <felipe@zimmerle.org>

debian/control
debian/rules

index b9d13ab..dbdb478 100644 (file)
@@ -2,13 +2,13 @@ Source: slock
 Section: apps
 Priority: extra
 Maintainer: Felipe Zimmerle <felipe@zimmerle.org>
-Build-Depends: debhelper (>= 7)
-Standards-Version: 3.8.1
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
 Homepage: http://slock.garage.maemo.org/
 
 Package: slock
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: Fancy screen lock
+Description: a fancy screen lock
  This software will provide a way to lock and unlock your device
  with a good relation between the usability and the security.
index 44fb029..ed2ad60 100755 (executable)
 
 
 
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0
+else
+       CFLAGS += -O2
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -24,7 +31,7 @@ configure-stamp:
 
 build: build-stamp
 
-build-stamp: configure-stamp  
+build-stamp: configure-stamp 
        dh_testdir
 
        # Add here commands to compile the package.
@@ -33,20 +40,20 @@ build-stamp: configure-stamp
 
        touch $@
 
-clean: 
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       #$(MAKE) clean
+       #-$(MAKE) clean
 
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_prep  
+       dh_clean -k 
        dh_installdirs
 
        # Add here commands to install the package into debian/slock.
@@ -54,11 +61,11 @@ install: build
 
 
 # Build architecture-independent files here.
-binary-indep: install
+binary-indep: build install
 # We have nothing to do by default.
 
 # Build architecture-dependent files here.
-binary-arch: install
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -66,7 +73,7 @@ binary-arch: install
        dh_installexamples
 #      dh_install
 #      dh_installmenu
-#      dh_installdebconf
+#      dh_installdebconf       
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam