Update some gtk stuff, add redundant debug info to hildon-desktop and improve README
[oespirit1] / gtk+ / gtk+_2.12.12.bb
1 # 01/06/09 15:33:17  Kirtika B Ruchandani <kirtibr@gmail.com> 
2 # Temporary recipe for Maemo GTK for testing 
3 # Copied over from the 2.12.11 bb file and modified
4
5 require gtk+.inc
6
7 # Temporary addition for testing
8 # to get rid of the vagaries of the 
9 # standalone gdk-pixbuf recipe
10 PROVIDES = "gdk-pixbuf"
11 RPROVIDES = "gdk-pixbuf"
12
13 PR = "r103"
14
15 DEPENDS += "cairo"
16
17 DEFAULT_PREFERENCE = 1
18
19 S="${WORKDIR}/gtk+2.0-2.12.12"
20
21 #FIXME : Patches currently used are only to get the build working. After testing on the device,
22 #uncomment the required patches
23
24 SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${PV}-1maemo12+0m5.tar.gz \
25            file://gtk+2.0-2.12.12/mer-changes.patch;patch=1 \
26            file://gtk+2.0-2.12.12/mkinstalldirs \
27            file://gtk+2.0-2.12.12/no-demos.patch;patch=1 \
28            file://gtk+2.0-2.12.12/xsettings.patch;patch=1 \
29 #          file://gtk+2.0-2.12.12/run-iconcache.patch;patch=1 \
30 #          file://gtk+2.0-2.12.12/hardcoded_libtool.patch;patch=1 \
31            file://gtk+2.0-2.12.12/cellrenderer-cairo.patch;patch=1;pnum=0 \
32            file://gtk+2.0-2.12.12/png-use-old-symbol.patch;patch=1;pnum=0 \
33            file://gtk+2.0-2.12.12/entry-cairo.patch;patch=1;pnum=0 "
34 #           file://gtk+2.0-2.12.12/toggle-font.diff;patch=1;pnum=0 \
35 #           file://gtk+2.0-2.12.12/scrolled-placement.patch;patch=1;pnum=0 \
36 # temporary
37 #           file://gtk+2.0-2.12.12/gtklabel-resize-patch;patch=1 \
38 #           file://gtk+2.0-2.12.12/menu-deactivate.patch;patch=1 \
39 #           file://gtk+2.0-2.12.12/combo-arrow-size.patch;patch=1;pnum=0 \
40 # die die die
41 #           file://gtk+2.0-2.12.12/pangoxft2.10.6.diff;patch=1"
42
43 EXTRA_OECONF = "--with-libtiff --with-gdktarget=x11 --disable-xkb --enable-display-migration --disable-gtk-doc --with-maemo=yes --with-libpng --with-libjpeg --with-x "
44
45
46 #Used for the gdk-pixbuf stuff
47 EXTRA_OECONF += "--with-included-loaders=png,tga --disable-gtk-doc"
48
49
50
51
52 LIBV = "2.10.0"
53
54 PACKAGES_DYNAMIC = "gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
55
56 do_configure_prepend(){
57     touch gtk-doc.make
58 }
59
60 python populate_packages_prepend () {
61         import os.path
62
63         prologue = bb.data.getVar("postinst_prologue", d, 1)
64
65         gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
66         loaders_root = os.path.join(gtk_libdir, 'loaders')
67         immodules_root = os.path.join(gtk_libdir, 'immodules')
68         printmodules_root = os.path.join(gtk_libdir, 'printbackends');
69
70         do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', prologue + 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
71         do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules')
72         do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
73
74         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
75                 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
76 }
77
78 # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
79 require gtk-fpu.inc
80 EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
81
82
83 PACKAGES += "gdk-pixbuf"
84
85 FILES_gdk-pixbuf = " ${bindir}/gdk-pixbuf-query-loaders \
86                          ${bindir}/gtk-update-icon-cache \
87                          ${libdir}/libgdk*"
88
89
90
91 # Needed while Testing 
92 do_rm_work(){
93     :
94 }