Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / scripts / debian / rules
1 #!/usr/bin/make -f
2
3 tmp=debian/tmp
4
5 build:
6
7 binary-arch:
8         echo "Hi, in an arch: all package, I am a bug!"
9
10 binary-indep:
11         install -d $(tmp)/usr/bin/
12         install -d $(tmp)/etc/X11/Xsession.d/
13         install -d $(tmp)/etc/init.d/
14         install -d $(tmp)/etc/csh/login.d/
15         install -d $(tmp)/etc/fish.d/
16         install -d $(tmp)/usr/share/scripts/
17         install -d $(tmp)/usr/share/doc/scripts/
18         install -d $(tmp)/usr/lib/python2.3/site-packages/
19         install -d $(tmp)/usr/lib/cgi-bin
20         install -d $(tmp)/usr/src/scripts
21         install -d $(tmp)/DEBIAN
22
23         install -m 755 csh-foo $(tmp)/etc/csh/login.d/ 
24         install -m 755 envfoo $(tmp)/usr/bin/
25         install -m 755 fish-foo $(tmp)/etc/fish.d/
26         install -m 755 jruby-broken $(tmp)/usr/bin/
27         install -m 755 pyfoo $(tmp)/usr/bin/
28         install -m 755 py2foo $(tmp)/usr/bin/
29         install -m 755 perlfoo $(tmp)/usr/bin/
30         install -m 755 rubyfoo $(tmp)/usr/bin/
31         install -m 755 make-foo $(tmp)/usr/bin/
32         install -m 755 lefty-foo $(tmp)/usr/bin/
33         install -m 4751 perlfoo $(tmp)/usr/bin/suidperlfoo2
34         install -m 755 sh-broken $(tmp)/usr/bin/
35         install -m 4555 suidperlfoo $(tmp)/usr/bin/
36         install -m 755 tkfoo $(tmp)/usr/bin/
37         install -m 755 wishfoo $(tmp)/usr/bin/
38         install -m 644 xsession-test $(tmp)/etc/X11/Xsession.d/
39
40 # Permissions here aren't part of what's being tested, but let us exercise
41 # some other errors.
42         install -m 755 perl-bizarre-1 $(tmp)/usr/bin/
43         install -m 750 perl-bizarre-2 $(tmp)/usr/bin/
44         install -m 754 perl-bizarre-3 $(tmp)/usr/bin/
45         install -m 705 guile-bizarre $(tmp)/usr/bin/
46
47 # First one should produce a warning; second one shouldn't.
48         install -m 755 gccbug.dpatch $(tmp)/usr/share/scripts/
49         install -m 755 gccbug.dpatch $(tmp)/usr/src/scripts/
50
51         install -m 644 init-skeleton $(tmp)/etc/init.d/skeleton
52         install -m 755 init-no-lsb $(tmp)/etc/init.d/no-lsb
53         install -m 755 init-lsb-broken $(tmp)/etc/init.d/lsb-broken
54         install -m 755 init-lsb-other $(tmp)/etc/init.d/lsb-other
55
56         install -m 755 phpfoo $(tmp)/usr/share/scripts/
57         sed 's/php$$/php5/' phpfoo > $(tmp)/usr/share/scripts/php5foo
58         chmod 755 $(tmp)/usr/share/scripts/php5foo
59
60         echo "#!/usr/bin/perl" >> $(tmp)/usr/share/scripts/foobar.in
61         chmod 644 $(tmp)/usr/share/scripts/foobar.in
62
63         touch $(tmp)/usr/share/scripts/mono.exe
64         chmod 755 $(tmp)/usr/share/scripts/mono.exe
65
66         echo "#!/bin/sh" > $(tmp)/usr/share/scripts/foo\$$bar
67         chmod 755 $(tmp)/usr/share/scripts/foo\$$bar
68
69         echo "#!/bin/sh" > $(tmp)/usr/lib/cgi-bin/cgi-script
70         chmod 755 $(tmp)/usr/lib/cgi-bin/cgi-script
71
72         echo "#!/bin/sh" > $(tmp)/usr/bin/test.sh
73         chmod 755 $(tmp)/usr/bin/test.sh
74
75 # Should produce complaints about a missing debhelper dependency, but not a
76 # missing Python dependency.
77         dh_python
78
79         touch $(tmp)/usr/lib/python2.3/site-packages/test.pyc
80         install -m 644 debian/changelog $(tmp)/usr/share/doc/scripts/changelog.Debian
81         gzip -9 $(tmp)/usr/share/doc/scripts/changelog.Debian
82         install -m 644 debian/copyright $(tmp)/usr/share/doc/scripts/copyright
83
84         install -m 644 debian/scripts.conffiles $(tmp)/DEBIAN/conffiles
85         install -m 755 debian/preinst $(tmp)/DEBIAN/preinst
86         install -m 755 debian/postinst $(tmp)/DEBIAN/postinst
87         install -m 755 debian/postrm $(tmp)/DEBIAN/postrm
88         touch $(tmp)/DEBIAN/prerm
89         chmod 755 $(tmp)/DEBIAN/prerm
90         dpkg-gencontrol -isp
91         dpkg --build $(tmp) ..
92
93 binary: binary-arch binary-indep
94
95 clean:
96         rm -rf debian/files $(tmp) debian/substvars
97
98 .PHONY: build binary-arch binary-indep binary clean