Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / relations / debian / rules
1 #!/usr/bin/make -f
2
3 # Copyright (C) 1998 Richard Braakman
4
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9
10 # This program is distributed in the hope that it will be useful,
11 # but WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
13 # GNU General Public License for more details.
14
15 # You should have received a copy of the GNU General Public License
16 # along with this program.  If not, you can find it on the World Wide
17 # Web at http://www.gnu.org/copyleft/gpl.html, or write to the Free
18 # Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
19 # MA 02110-1301, USA.
20
21 build:
22
23 binary-arch:
24
25 binary-indep:
26         install -d debian/tmp/DEBIAN
27         dpkg-gencontrol -prelations -isp
28         dpkg --build debian/tmp ../relations_5_all.deb
29         install -d debian/tmp/usr/share/doc/
30         ln -s relations debian/tmp/usr/share/doc/relations-multiple-libs
31         dpkg-gencontrol -prelations-multiple-libs -isp
32         dpkg --build debian/tmp ../relations-multiple-libs_5_all.deb
33
34 binary: binary-arch binary-indep
35
36 clean::
37         rm -rf debian/tmp debian/files
38
39 # Test that python-all-dev satisfies a Python requirement.
40         python -V || true
41
42 # Test allowing quilt Build-Depends for manual quilt invocations.
43         TESTING=foo ANOTHER=bar quilt || true
44
45 # Test requiring perl Build-Depends for manual perl invocations.
46         [ ! -f Build ] || $(PERL) Build distclean
47
48 .PHONY: build binary-arch binary-indep binary clean