Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / etcfiles / debian / rules
1 #!/usr/bin/make -f
2
3 tmp=debian/tmp
4 tmponly=debian/only-etcfiles
5
6 clean:
7         rm -f debian/files debian/substvars
8         rm -rf debian/tmp
9         rm -rf debian/only-etcfiles
10
11 build:
12 binary-indep:
13         install -d $(tmp)/etc
14         install -m 644 proper $(tmp)/etc
15         install -m 644 improper $(tmp)/etc
16         mkdir $(tmp)/etc/cron.daily
17         touch $(tmp)/etc/cron.daily/cronfile-normal
18         touch $(tmp)/etc/cron.daily/.cronfile-begins-with-fullstop
19         touch $(tmp)/etc/cron.daily/cronfile-contains.fullstop
20         ln $(tmp)/etc/improper $(tmp)/etc/improper-link
21         install -d $(tmp)/usr/share/doc/etcfiles
22         install -d $(tmp)/var/lib
23         install -m 644 proper $(tmp)/var/lib/foo
24         install -m 644 debian/README.Debian $(tmp)/usr/share/doc/etcfiles
25         install -m 644 debian/changelog $(tmp)/usr/share/doc/etcfiles
26         #gzip -9 $(tmp)/usr/share/doc/etcfiles/changelog
27         install -d $(tmp)/DEBIAN
28         install -m 644 debian/conffiles $(tmp)/DEBIAN
29
30         echo '68b329da9893e34099c7d8ad5cb9c940  ./etc/cron.daily/cronfile-normal' \
31             > debian/tmp/DEBIAN/md5sums
32         echo '68b329da9893e34099c7d8ad5cb9c940  ./etc/cron.daily/.cronfile-begins-with-fullstop' \
33             > debian/tmp/DEBIAN/md5sums
34         echo '68b329da9893e34099c7d8ad5cb9c940  ./etc/cron.daily/cronfile-contains.fullstop' \
35             > debian/tmp/DEBIAN/md5sums
36         echo 'ab371382468880299e5ebd05921764ce  ./etc/proper' \
37             > debian/tmp/DEBIAN/md5sums
38         echo 'ab371382468880299e5ebd05921764ce  etc/improper' \
39             >> debian/tmp/DEBIAN/md5sums
40         echo 'ab371382468880299e5ebd05921764ce  usr/bin/foo' \
41             >> debian/tmp/DEBIAN/md5sums
42         echo 'this is a malformed line' \
43             >> debian/tmp/DEBIAN/md5sums
44         echo '56fb27e455dd86d8801f1ecd3a4cee49  usr/share/doc/etcfiles/README.Debian' \
45             >> debian/tmp/DEBIAN/md5sums
46
47         install -d $(tmponly)/etc/etcfiles
48         touch $(tmponly)/etc/etcfiles/foo
49         touch $(tmponly)/etc/etcfiles/bar
50         install -d $(tmponly)/usr/share/doc
51         cd $(tmponly)/usr/share/doc && ln -s etcfiles only-etcfiles
52         install -d $(tmponly)/DEBIAN
53         install -m 644 debian/conffiles.only $(tmponly)/DEBIAN/conffiles
54
55         dpkg-gencontrol -isp -petcfiles
56         dpkg-gencontrol -isp -ponly-etcfiles -P$(tmponly)
57         dpkg --build $(tmp) ..
58         dpkg --build $(tmponly) ..
59
60 binary: binary-indep
61
62 .PHONY: binary-indep binary clean