Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / empty / debian / rules
1 #!/usr/bin/make -f
2
3 # Copyright (C) 1998 Richard Braakman
4
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9
10 # This program is distributed in the hope that it will be useful,
11 # but WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
13 # GNU General Public License for more details.
14
15 # You should have received a copy of the GNU General Public License
16 # along with this program.  If not, you can find it on the World Wide
17 # Web at http://www.gnu.org/copyleft/gpl.html, or write to the Free
18 # Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
19 # MA 02110-1301, USA.
20
21 build:
22
23 binary-indep:
24         install -d debian/empty debian/empty/DEBIAN
25         dpkg-gencontrol -pempty -Pdebian/empty
26         dpkg --build debian/empty ..
27         install -d debian/empty-docs debian/empty-docs/DEBIAN
28         dpkg-gencontrol -pempty-docs -Pdebian/empty-docs
29         dpkg --build debian/empty-docs ..
30         install -d debian/libempty-perl debian/libempty-perl/DEBIAN
31         dpkg-gencontrol -plibempty-perl -Pdebian/libempty-perl
32         dpkg --build debian/libempty-perl ..
33         install -d debian/python-empty debian/python-empty/DEBIAN
34         dpkg-gencontrol -ppython-empty -Pdebian/python-empty
35         dpkg --build debian/python-empty ..
36
37 binary: binary-indep
38
39 clean:
40         rm -rf $(CURDIR)/debian/empty $(CURDIR)/debian/empty-docs \
41                 $(CURDIR)/debian/libempty-perl $(CURDIR)/debian/python-empty \
42                 debian/files
43
44 .PHONY: build binary-indep binary clean