Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / diffs / debian / rules
1 #!/usr/bin/make -f
2
3 package := diffs
4 tmp := debian/tmp
5
6 build:
7         make
8
9 binary-arch:
10
11 binary-indep:
12         install -d $(tmp)/usr/bin/
13         install -d $(tmp)/usr/share/doc/$(package)/
14         install -d $(tmp)/DEBIAN
15
16         install -m 755 binary $(tmp)/usr/bin/$(package)
17         gzip -c9 ChangeLog > $(tmp)/usr/share/doc/$(package)/changelog.gz
18         gzip -c9 debian/changelog > $(tmp)/usr/share/doc/$(package)/changelog.Debian.gz
19
20         dpkg-gencontrol -isp
21         dpkg --build $(tmp) ..
22
23 binary: binary-arch binary-indep
24
25 clean:
26         rm -rf $(tmp)
27         make clean
28         rm -f subdir-good/config.cache subdir-good/config.log subdir-good/config.status
29
30 .PHONY: build binary-arch binary-indep binary clean