Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / debug / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper. 
3 # This file is public domain software, originally written by Joey Hess.
4
5 export DH_COMPAT := 5
6
7 build: build-stamp
8 build-stamp:
9         dh_testdir
10         gcc -D_REENTRANT -fPIC -c libhello.c
11         gcc -o libhello.so.0.0 -shared -Wl,-soname,libhello.so.0 libhello.o
12         ln -s libhello.so.0.0 libhello.so
13         gcc -o hello hello.c -L. -lhello
14         touch build-stamp
15
16 clean:
17         dh_testdir
18         dh_testroot
19         rm -f build-stamp *.o libhello.so.0.0
20         dh_clean
21
22 install: build-stamp
23         dh_testdir
24         dh_testroot
25         dh_clean -k
26         install -D hello $(CURDIR)/debian/hello/usr/bin/hello
27         install -D libhello.so.0.0 \
28             $(CURDIR)/debian/libhello0/usr/lib/libhello.so.0.0
29         ln -s libhello.so.0.0 \
30             $(CURDIR)/debian/libhello0/usr/lib/libhello.so.0
31
32 # Build architecture-dependent files here.
33 export DH_OPTIONS
34 binary-arch: DH_OPTIONS=-a
35 binary-arch: build-stamp install
36         dh_testdir
37         dh_testroot
38         dh_installchangelogs
39         dh_installdocs
40         DH_OPTIONS= dh_strip -phello --dbg-package=hello-dbg
41         DH_OPTIONS= dh_strip -plibhello0 --dbg-package=libhello0-dbg
42
43         # Now break a few things.  Copy the debugging data into places it
44         # shouldn't be.
45         cp $(CURDIR)/debian/hello-dbg/usr/lib/debug/usr/bin/hello \
46             $(CURDIR)/debian/hello/usr/bin/hello.dbg
47         cp $(CURDIR)/debian/libhello0-dbg/usr/lib/debug/usr/lib/libhello.so.0.0 \
48             $(CURDIR)/debian/libhello0-dbg/usr/lib/libhello.so.dbg
49
50         # Put a full copy of the library in libhello0-dbg in /usr/lib/debug,
51         # which is okay.
52         install -m 644 libhello.so.0.0 \
53             $(CURDIR)/debian/libhello0-dbg/usr/lib/debug/libhello.so.0.0
54
55         # Also put it in /usr/lib/debug/lib, which isn't.
56         install -D -m 644 libhello.so.0.0 \
57             $(CURDIR)/debian/libhello0-dbg/usr/lib/debug/lib/libhello.so.0.0
58
59         # Requires a versioned dependency.
60         dh_icons
61
62         dh_link
63         dh_compress
64         dh_fixperms
65         dh_makeshlibs -X debug
66         dh_installdeb
67         dh_shlibdeps -X debug
68
69         # We do this by hand as otherwise dpkg-gensymbols
70         # will error due to the broken symbols file
71         # and abort the build; similarly the file in
72         # the source tree is _symbols so that dpkg
73         # doesn't attempt to sanity check it
74         install -d $(CURDIR)/debian/libhello0/DEBIAN
75         install -m 644 $(CURDIR)/debian/_symbols \
76             $(CURDIR)/debian/libhello0/DEBIAN/symbols
77         # hello doesn't contain any shlibs, but we
78         # make it contain a symbols file
79         install -d $(CURDIR)/debian/hello/DEBIAN
80         install -m 644 $(CURDIR)/debian/_symbols \
81             $(CURDIR)/debian/hello/DEBIAN/symbols
82
83         dh_gencontrol
84         dh_md5sums
85         dh_builddeb
86
87 binary-indep:
88 binary: binary-indep binary-arch
89 .PHONY: binary binary-indep binary-arch build clean install