Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / debconf / debian / rules
1 #!/usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 deb_dir         =       debian/debconf
6 udeb_dir        =       debian/debconf-udeb
7 build_dirs      =       $(deb_dir) $(udeb_dir)
8
9 build:
10         dh_testdir
11         touch build
12
13 clean:
14         dh_testdir
15         dh_testroot
16         -rm -f build
17
18         dh_clean
19
20 binary-indep:   build
21 # There are no architecture-independent files to be uploaded
22 # generated by this package.  If there were any they would be
23 # made here.
24
25 binary-arch:    build
26         dh_testdir
27         dh_testroot
28         dh_clean -k -a
29         dh_installdirs -a
30
31         dh_installchangelogs -a
32         dh_installdocs -a
33         dh_installdebconf -pdebconf-test
34         dh_installdebconf -pdebconf-test-noscripts --noscripts
35         dh_installdebconf -pdebconf-test-preinst --noscripts
36         dh_installdebconf -pdebconf-test-postinst --noscripts
37         dh_installdebconf -pdebconf-udeb
38
39         # Not needed, but it tests dh_python build dependencies.
40         dh_python -a
41
42         dh_compress -a
43         dh_fixperms -a
44
45 # The shlibs stuff doesn't matter here so do it in a weird order to
46 # test wwarnings.
47         dh_installdeb -a
48         dh_shlibdeps -a
49         dh_makeshlibs -a
50         dh_gencontrol -a
51         dh_md5sums
52         dh_builddeb -a
53         dh_makeshlibs -a
54
55 # Below here is fairly generic really
56
57 binary:         binary-indep binary-arch
58
59 .PHONY: binary binary-arch binary-indep clean checkroot