Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / rules
1 #!/usr/bin/make -f
2
3 VER := $(shell head -1 debian/changelog | sed -e 's/^.*(//' -e 's/).*$$//')
4 tmp := $(CURDIR)/debian/lintian
5 usl := $(tmp)/usr/share/lintian
6 neededfiles := debian/rules frontend/lintian
7 allchecks := $(wildcard checks/*)
8 allcollect := $(wildcard collection/*)
9 tagfiles := $(wildcard testset/tags.*)
10 onlyrun =
11
12 runtests: $(neededfiles) $(allchecks) $(allcollect) $(tagfiles)
13         @echo .... running tests ....
14         [ -d debian/tests ] || mkdir debian/tests
15         LINTIAN_ROOT="" /usr/bin/perl testset/runtests -k testset debian/tests $(onlyrun)
16         touch $@
17
18 build: $(neededfiles)
19         @echo .... running build ....
20         dh_testdir
21         cd doc && LANG=C debiandoc2html lintian.sgml
22         cd doc && LANG=C debiandoc2text lintian.sgml
23
24 clean: $(neededfiles)
25         @echo .... cleaning ....
26         dh_testdir
27         dh_testroot
28         rm -f runtests
29         rm -rf doc/lintian.html/ doc/lintian.txt
30         rm -rf debian/tests
31         find -name "*.py?" -print0 | xargs -0r rm
32         dh_clean -Xtestset/diffs/binary.c~
33
34 binary-indep: $(neededfiles) build
35         @echo .... binary-indep ....
36         dh_testdir
37         dh_testroot
38         dh_clean -k -Xtestset/diffs/binary.c~
39         dh_installdirs
40
41 # frontends
42         @echo .... install frontends ....
43         install -m 755 frontend/lintian $(tmp)/usr/bin/
44         sed -i 's/<VERSION>/$(VER)/' $(tmp)/usr/bin/lintian
45         install -m 755 frontend/lintian-info $(tmp)/usr/bin/
46 # library files
47         @echo .... install library files ....
48         find checks collection data lib unpack \
49             \( -path '*/CVS' -o -path '*/.svn' \) -prune -o -print \
50                 | cpio -admp $(usl)
51 # documentation
52         @echo .... install documentation ....
53         dh_installdocs
54         dh_installchangelogs
55 # manual pages
56         @echo .... install manual pages ....
57         dh_installman man/*.1
58 # config file
59         @echo .... install config file ....
60         install -m 644 doc/lintianrc.example $(tmp)/etc/lintianrc
61 # control files
62         @echo .... fix things up and build packages ....
63         dh_compress
64         dh_fixperms
65         dh_installdeb
66         dh_gencontrol
67         dh_md5sums
68         dh_builddeb
69
70 binary-arch:
71
72 binary: binary-indep binary-arch
73
74 .PHONY: build binary binary-arch binary-indep clean
75 .DELETE_ON_ERROR: runtests
76 include debian/rules.OSSO