Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / rules.OSSO
1 FORCE =
2
3 prepare:
4         $(MAKE) -f debian/rules.OSSO \
5                 debian/changelog      \
6                 debian/control        \
7                 debian/patches/00list \
8                 debian/rules          \
9                 FORCE=FORCE
10
11 debian/changelog: $(FORCE)
12         chmod 755 debian/scripts/*
13         umask 022 && debian/scripts/mergechangelogs $@ $@.OSSO >$@.new~
14         mv $@.new~ $@
15
16 debian/control: $(FORCE)
17         sed \
18                 -i \
19                 -e '/^Build-Depends-Indep:/!b' \
20                 -e 's/, dpatch$$//'            \
21                 -e 's/$$/, dpatch/'            \
22                 $@
23
24 debian/patches/00list: $(FORCE)
25         umask 022 && \
26         cd debian/patches/ && \
27         LC_ALL=C ls [0-9][0-9][0-9]-*.dpatch | \
28         sed 's/[.]dpatch$$//' >00list
29
30 debian/rules: $(FORCE)
31         line='include debian/rules.OSSO'; \
32         sed \
33                 -i \
34                 -e '$$a\'              \
35                 -e "$$line"            \
36                 -e '\:^'"$$line"'$$:d' \
37                 $@
38
39 clean: unpatch
40 binary-indep: patch
41
42 patch: patch-stamp
43 patch-stamp:
44         dpatch apply-all
45         touch $@
46
47 unpatch:
48         dpatch deapply-all
49         rm -fr patch-stamp debian/patched
50
51 FORCE:
52
53 .PHONY: prepare patch unpatch FORCE