Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / patches / 804-xargs-fix-bts-399322.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 804-xargs-fix-bts-399322.dpatch by Alexander Kanevskiy <alexander.kanevskiy@nokia.com>>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Ignore errors for ARM binaries which binutils-multiarch can't parse
6
7 @DPATCH@
8 --- lintian/collection/file-info        2007-05-22 12:31:27.000000000 +0300
9 +++ lintian/collection/file-info        2007-03-10 08:55:49.000000000 +0200
10 @@ -16,8 +16,8 @@
11  # You should have received a copy of the GNU General Public License
12  # along with this program.  If not, you can find it on the World Wide
13  # Web at http://www.gnu.org/copyleft/gpl.html, or write to the Free
14 -# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
15 -# MA 02111-1307, USA.
16 +# Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
17 +# MA 02110-1301, USA.
18  
19  use strict;
20  
21 @@ -44,7 +44,8 @@
22      chop;
23      $_ = (split(" ", $_, 6))[5];
24      s/ link to .*//;
25 -    s/ -> .*//; 
26 +    s/ -> .*//;
27 +    s/(\G|[^\\](?:\\\\)*)\\(\d{3})/"$1" . chr(oct $2)/ge;
28      s/\\\\/\\/;
29      printf $XARGS "%s\0", $_;
30  }