Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / patches / 803-ignore-unknown-elf-format.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 803-ignore-unknown-elf-format.dpatch by Alexander Kanevskiy <alexander.kanevskiy@nokia.com>>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Ignore errors for ARM binaries which binutils-multiarch can't parse
6
7 @DPATCH@
8 diff -urN lintian-1.23.8.org/checks/binaries lintian-1.23.8/checks/binaries
9 --- lintian-1.23.8.org/checks/binaries  2006-11-19 13:00:11.574699515 +0200
10 +++ lintian-1.23.8/checks/binaries      2006-11-19 12:49:01.000000000 +0200
11 @@ -104,7 +104,8 @@
12         } elsif (m/^DYNAMIC SYMBOL TABLE:/) {
13             $dynsyms = 1;
14         } elsif (m/^objdump: (.*?): File format not recognized$/) {
15 -           fail("file format not recognized for $1\nif you are checking non-i386 binaries, you'll need to install binutils-multiarch\n");
16 +           #fail("file format not recognized for $1\nif you are checking non-i386 binaries, you'll need to install binutils-multiarch\n");
17 +           tag "binary-file-format-not-recognized", "$1";
18         } elsif (m/^objdump: \.(.*?): Packed with UPX$/) {
19             tag "binary-file-compressed-with-upx", "$1";
20         } elsif (m/^objdump: \.(.*?): Invalid operation$/) {
21 diff -urN lintian-1.23.8.org/checks/binaries.desc lintian-1.23.8/checks/binaries.desc
22 --- lintian-1.23.8.org/checks/binaries.desc     2006-11-19 13:00:11.460701400 +0200
23 +++ lintian-1.23.8/checks/binaries.desc 2006-11-19 12:50:40.000000000 +0200
24 @@ -145,3 +145,8 @@
25  Info: This appears to be an ELF file but objdump -T cannot parse it.
26   If it is external debugging symbols for another file, it should be
27   installed under /usr/lib/debug.
28 +
29 +Tag: binary-file-format-not-recognized
30 +Type: warning
31 +Info: objdump can't recognize file format for that binary.
32 +
33 diff -urN lintian-1.23.8.org/collection/objdump-info lintian-1.23.8/collection/objdump-info
34 --- lintian-1.23.8.org/collection/objdump-info  2006-11-19 13:00:11.504700673 +0200
35 +++ lintian-1.23.8/collection/objdump-info      2006-11-19 12:43:09.000000000 +0200
36 @@ -58,7 +58,7 @@
37             # If the objdump error is "Invalid operation", we handle it later
38             # in the check script, since this is the expected output (for now)
39             # on detached debugging information in /usr/lib/debug.
40 -           if objdump -T $bin 2>&1 | grep -q 'Invalid operation$' ; then
41 +           if objdump -T $bin 2>&1 | grep -qE 'Invalid operation$|File format not recognized$' ; then
42                 :
43             else
44                 exit 1