Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / patches / 801-allow-dynamic-loaders.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 801-allow-dynamic-loaders.dpatch by Eero Häkkinen <eero.hakkinen@nokia.com>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Allow dynamic loaders with executable permissions.
6
7 @DPATCH@
8 diff -urNad lintian~/checks/shared-libs lintian/checks/shared-libs
9 --- lintian~/checks/shared-libs 2006-09-21 15:28:04.000000000 +0300
10 +++ lintian/checks/shared-libs  2006-09-21 15:28:04.000000000 +0300
11 @@ -169,8 +169,10 @@
12              if ($real_perm =~ m/x/) {
13                  # yes.  But if the library has an INTERP section, it's designed
14                  # to do something useful when executed, so don't report an error.
15 +                # Patch:
16 +                # Dynamic loaders must be executable.
17                  tag "shlib-with-executable-bit", $cur_file, sprintf("%04o",perm2oct($real_perm))
18 -                    unless $INTERP{$real_file};
19 +                    unless $INTERP{$real_file} or $SONAME{$real_file} =~ /^ld-/os;
20              } elsif ($real_perm ne '-rw-r--r--') {
21                  # bad permissions
22                  tag "shlib-with-bad-permissions", $cur_file, sprintf("%04o",perm2oct($real_perm));