Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / debian / patches / 500-backport-1.23.22-tar-wildcard.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 500-backport-1.23.22-tar-wildcard.dpatch by Eero Häkkinen <eero.hakkinen@nokia.com>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Pass the --wildcards option to tar, now required by a change in the
6 ## DP: default tar semantics.
7
8 @DPATCH@
9 diff -urNad lintian-1.23.8/lib/Util.pm lintian-1.23.22/lib/Util.pm
10 --- lintian-1.23.8/lib/Util.pm  2006-07-18 12:04:27.000000000 +0000
11 +++ lintian-1.23.22/lib/Util.pm 2006-07-18 12:05:25.000000000 +0000
12 @@ -139,7 +139,7 @@
13      my $CONTROL = FileHandle->new;
14      pipeline_open($CONTROL,
15                   (sub { exec 'ar', 'p', $file, 'control.tar.gz' }),
16 -                 (sub { exec 'tar', 'xfzO', '-', '*control' }))
17 +                 (sub { exec 'tar', '--wildcards', '-xzO', '-f', '-', '*control' }))
18         or fail("cannot fork to unpack $file: $!\n");
19      my @data = parse_dpkg_control($CONTROL);
20      close($CONTROL) or fail("broken input pipe for unpacking $file: $!");