Add new patch asix-ethernet.patch
[kernel-power] / kernel-power-2.6.28 / debian / patches / asix-ethernet.patch
1 --- kernel-power-2.6.28/drivers/net/usb/asix.c  2012-07-23 06:37:35.000000000 -0700
2 +++ kernel-power-2.6.28/drivers/net/usb/asix.c  2013-08-15 15:18:04.872495100 -0700
3 @@ -1391,6 +1391,10 @@
4         USB_DEVICE (0x6189, 0x182d),
5         .driver_info =  (unsigned long) &ax8817x_info,
6  }, {
7 +       // Sitecom LN-031 "USB 2.0 10/100/1000 Ethernet adapter"
8 +       USB_DEVICE (0x0df6, 0x0056),
9 +       .driver_info =  (unsigned long) &ax88178_info,
10 +}, {
11         // corega FEther USB2-TX
12         USB_DEVICE (0x07aa, 0x0017),
13         .driver_info =  (unsigned long) &ax8817x_info,
14 @@ -1407,6 +1411,10 @@
15         USB_DEVICE (0x04f1, 0x3008),
16         .driver_info = (unsigned long) &ax8817x_info,
17  }, {
18 +       // Lenovo U2L100P 10/100
19 +       USB_DEVICE (0x17ef, 0x7203),
20 +       .driver_info = (unsigned long) &ax88772_info,
21 +}, {
22         // ASIX AX88772 10/100
23         USB_DEVICE (0x0b95, 0x7720),
24         .driver_info = (unsigned long) &ax88772_info,
25 @@ -1415,6 +1423,10 @@
26         USB_DEVICE (0x0b95, 0x1780),
27         .driver_info = (unsigned long) &ax88178_info,
28  }, {
29 +       // Logitec LAN-GTJ/U2A
30 +       USB_DEVICE (0x0789, 0x0160),
31 +       .driver_info = (unsigned long) &ax88178_info,
32 +}, {
33         // Linksys USB200M Rev 2
34         USB_DEVICE (0x13b1, 0x0018),
35         .driver_info = (unsigned long) &ax88772_info,
36 @@ -1431,6 +1443,10 @@
37         USB_DEVICE (0x2001, 0x3c05),
38         .driver_info = (unsigned long) &ax88772_info,
39  }, {
40 +       // DLink DUB-E100 H/W Ver C1
41 +       USB_DEVICE (0x2001, 0x1a02),
42 +       .driver_info = (unsigned long) &ax88772_info,
43 +}, {
44         // Linksys USB1000
45         USB_DEVICE (0x1737, 0x0039),
46         .driver_info = (unsigned long) &ax88178_info,
47 @@ -1458,6 +1474,10 @@
48         // ASIX 88772a
49         USB_DEVICE(0x0db0, 0xa877),
50         .driver_info = (unsigned long) &ax88772_info,
51 +}, {
52 +       // Asus USB Ethernet Adapter
53 +       USB_DEVICE (0x0b95, 0x7e2b),
54 +       .driver_info = (unsigned long) &ax88772_info,
55  },
56         { },            // END
57  };