removing unused kernel-maemo files
[kernel-bfs] / kernel-power-2.6.28 / debian / patches / ppp_async_matan.diff
1 --- kernel-maemo-2.6.28.orig/drivers/net/ppp_async.c
2 +++ kernel-maemo-2.6.28/drivers/net/ppp_async.c
3 @@ -346,7 +346,7 @@
4   * This can now be called from hard interrupt level as well
5   * as soft interrupt level or mainline.
6   */
7 -static void
8 +static int
9  ppp_asynctty_receive(struct tty_struct *tty, const unsigned char *buf,
10                   char *cflags, int count)
11  {
12 @@ -354,7 +354,7 @@
13         unsigned long flags;
14  
15         if (!ap)
16 -               return;
17 +               return 0;
18         spin_lock_irqsave(&ap->recv_lock, flags);
19         ppp_async_input(ap, buf, cflags, count);
20         spin_unlock_irqrestore(&ap->recv_lock, flags);
21 @@ -362,6 +362,7 @@
22                 tasklet_schedule(&ap->tsk);
23         ap_put(ap);
24         tty_unthrottle(tty);
25 +       return count;
26  }
27  
28  static void