New version, including standard dbus service and building smoothly also under debian...
[wifihood] / wifiscand / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18         CFLAGS += -O0
19 else
20         CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25         dh_testdir
26         # Add here commands to configure the package.
27
28         touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp 
34         dh_testdir
35
36         # Add here commands to compile the package.
37         pkg-config --exists libosso ; \
38                 if [ $? -eq 0 ] ; then \
39                 echo $(MAKE) wifiscand CPPFLAGS="-DHAVE_LIBOSSO" ; \
40                 else \
41                 echo $(MAKE) wifiscand ; \
42                 fi
43
44         touch build-stamp
45
46 clean:
47         dh_testdir
48         dh_testroot
49         rm -f build-stamp configure-stamp
50
51         # Add here commands to clean up after the build process.
52         -$(MAKE) clean
53
54         dh_clean 
55
56 install: build
57         dh_testdir
58         dh_testroot
59         dh_clean -k 
60         dh_installdirs
61
62         # Add here commands to install the package into debian/tmp
63         make install DESTDIR=$(CURDIR)/debian/tmp
64
65
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
69
70 # Build architecture-dependent files here.
71 binary-arch: build install
72         dh_testdir
73         dh_testroot
74         dh_installchangelogs 
75         dh_installdocs
76         dh_installexamples
77 #       dh_install
78 #       dh_installmenu
79 #       dh_installdebconf       
80 #       dh_installlogrotate
81 #       dh_installemacsen
82 #       dh_installpam
83 #       dh_installmime
84 #       dh_installinit
85 #       dh_installcron
86 #       dh_installinfo
87         dh_installman
88         dh_link
89         dh_strip
90         dh_compress
91         dh_fixperms
92 #       dh_perl
93 #       dh_python
94 #       dh_makeshlibs
95         dh_installdeb
96         dh_shlibdeps
97         dh_gencontrol
98         dh_md5sums
99         dh_builddeb
100
101 binary: binary-indep binary-arch
102 .PHONY: build clean binary-indep binary-arch binary install configure