c0ded00fc06641ebde62b29aed18693db7298f88
[pkg-perl] / deb-src / libtest-exception-perl / libtest-exception-perl-0.27 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
13
14 PACKAGE=$(shell dh_listpackages)
15
16 ifndef PERL
17 PERL = /usr/bin/perl
18 endif
19
20 TMP     =$(CURDIR)/debian/$(PACKAGE)
21
22 build: build-stamp
23 build-stamp:
24         dh_testdir
25
26         $(PERL) Makefile.PL INSTALLDIRS=vendor
27         $(MAKE)
28         $(MAKE) test
29
30         touch $@
31
32 clean:
33         dh_testdir
34         dh_testroot
35
36         dh_clean build-stamp install-stamp
37         [ ! -f Makefile ] || $(MAKE) realclean
38
39 install: install-stamp
40 install-stamp: build-stamp
41         dh_testdir
42         dh_testroot
43         dh_clean -k
44
45         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
46         [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(TMP)/usr/lib/perl5
47
48         touch $@
49
50 binary-arch:
51 # We have nothing to do here for an architecture-independent package
52
53 binary-indep: build install
54         dh_testdir
55         dh_testroot
56         dh_installdocs
57         dh_installchangelogs Changes
58         dh_perl
59         dh_compress
60         dh_fixperms
61         dh_installdeb
62         dh_gencontrol
63         dh_md5sums
64         dh_builddeb
65
66 source diff:
67         @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
68
69 binary: binary-indep binary-arch
70 .PHONY: build clean binary-indep binary-arch binary install