Add the following packages libalgorithm-diff-perl libspiffy-perl libtext-diff-perl...
[pkg-perl] / deb-src / libspiffy-perl / libspiffy-perl-0.30 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
13
14 PERL   ?= /usr/bin/perl
15 PACKAGE = $(shell dh_listpackages)
16 TMP     = $(CURDIR)/debian/$(PACKAGE)
17
18 build: build-stamp
19 build-stamp:
20         dh_testdir
21         $(PERL) Makefile.PL INSTALLDIRS=vendor
22         $(MAKE)
23         $(MAKE) test
24         touch $@
25
26 clean:
27         dh_testdir
28         dh_testroot
29         dh_clean build-stamp install-stamp
30         [ ! -f Makefile ] || $(MAKE) realclean
31
32 install: install-stamp
33 install-stamp: build-stamp
34         dh_testdir
35         dh_testroot
36         dh_clean -k
37         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
38
39         # convert broken *roff from UTF-8 encoded modules
40         sed -i -e 's/A\\\*~X/\\\[:o\]/' $(TMP)/usr/share/man/man3/Spiffy.3pm
41
42         [ ! -d $(TMP)/usr/lib/perl5 ] || \
43                 rmdir --ignore-fail-on-non-empty --parents --verbose \
44                 $(TMP)/usr/lib/perl5
45         touch $@
46
47 binary-arch:
48 # We have nothing to do here for an architecture-independent package
49
50 binary-indep: build install
51         dh_testdir
52         dh_testroot
53         dh_installdocs
54         dh_installchangelogs Changes
55         dh_perl
56         dh_compress
57         dh_fixperms
58         dh_installdeb
59         dh_gencontrol
60         dh_md5sums
61         dh_builddeb
62
63 binary: binary-indep binary-arch
64 .PHONY: build clean binary-indep binary-arch binary install