Debian lenny version packages
[pkg-perl] / deb-src / libpod-coverage-perl / libpod-coverage-perl-0.19 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 PACKAGE=$(shell dh_listpackages)
9
10 ifndef PERL
11 PERL = /usr/bin/perl
12 endif
13
14 build: build-stamp
15 build-stamp:
16         dh_testdir
17         $(PERL) Build.PL installdirs=vendor
18         $(PERL) Build
19         $(PERL) Build test
20         touch $@
21
22 clean:
23         dh_testdir
24         dh_testroot
25         dh_clean build-stamp install-stamp
26         [ ! -f Build ] || $(PERL) Build distclean
27
28 install: install-stamp
29 install-stamp: build-stamp
30         dh_testdir
31         dh_testroot
32         dh_clean -k
33         
34         $(PERL) Build install destdir=$(CURDIR)/debian/$(PACKAGE) create_packlist=0
35         rm $(CURDIR)/debian/$(PACKAGE)/usr/bin/pod_cover
36         rmdir --parents --ignore-fail-on-non-empty $(CURDIR)/debian/$(PACKAGE)/usr/bin
37         find $(CURDIR)/examples -type f -exec chmod +x {} \;
38         find $(CURDIR)/bin -type f -exec chmod +x {} \;
39         
40         touch $@
41
42 binary-arch:;
43 binary-indep: build install
44         dh_testdir
45         dh_testroot
46         dh_installdocs
47         dh_installchangelogs Changes
48         dh_installexamples examples/* bin/*
49         dh_compress
50         dh_fixperms
51         dh_installdeb
52         dh_perl
53         dh_gencontrol
54         dh_md5sums
55         dh_builddeb
56
57 binary: binary-indep binary-arch
58 .PHONY: build clean binary-indep binary-arch binary install configure