Debian lenny version packages
[pkg-perl] / deb-src / libio-compress-base-perl / libio-compress-base-perl-2.012 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
13
14 PERL   ?= /usr/bin/perl
15 PACKAGE = $(shell dh_listpackages)
16 TMP     = $(CURDIR)/debian/$(PACKAGE)
17
18 build: build-stamp
19 build-stamp:
20         dh build --before auto_configure
21         $(PERL) Makefile.PL INSTALLDIRS=vendor INST_LIB='blib/lib'
22         dh build --after auto_configure
23         touch $@
24
25 clean:
26         dh $@
27
28 install: install-stamp
29 install-stamp: build-stamp
30         dh install --before auto_install
31         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
32         pod2man --section 3pm --name "IO::Compress::Base::FAQ" pod/FAQ.pod \
33                 > $(TMP)/usr/share/man/man3/IO::Compress::Base::FAQ.3pm
34         dh install --after auto_install
35         touch $@
36
37 binary-arch:
38 # We have nothing to do here for an architecture-independent package
39
40 binary-indep: install
41         dh $@
42
43 binary: binary-indep binary-arch
44 .PHONY: build clean binary-indep binary-arch binary install