Added correct PATH and SBOX_REDIRECT_IGNORE and PERL5LIB envs in rules for libhtml...
[pkg-perl] / deb-src / libhtml-parser-perl / libhtml-parser-perl-3.56 / debian / rules
1 #!/usr/bin/make -f
2
3 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
4 unexport PERL5LIB
5 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
6 PERL=/usr/bin/perl
7
8 binary: binary-arch
9
10 binary-arch: build install
11         dh_testdir
12         dh_testroot
13         dh_installdocs TODO
14         chmod a+x eg/hform
15         dh_installexamples eg/hanchors eg/hform eg/hrefsub eg/hstrip eg/htext eg/htextsub eg/htitle
16         dh_installchangelogs Changes
17         dh_strip
18         dh_fixperms
19         dh_compress
20         dh_installdeb
21         dh_perl
22         dh_shlibdeps
23         dh_gencontrol
24         dh_md5sums
25         dh_builddeb
26
27 binary-indep: 
28
29 install: build
30         dh_testdir
31         dh_testroot
32         dh_installdirs
33         $(MAKE) install INSTALLDIRS=vendor PREFIX=$(CURDIR)/debian/libhtml-parser-perl/usr
34         rm -rf debian/libhtml-parser-perl/usr/share/perl5
35
36 build: configure-stamp build-stamp
37 build-stamp:
38         dh_testdir
39         $(MAKE) OPTIMIZE="-O2 -g -Wall"
40         $(MAKE) test
41         touch build-stamp
42
43 configure: configure-stamp
44 configure-stamp:
45         dh_testdir
46         $(PERL) Makefile.PL INSTALLDIRS=vendor
47         touch configure-stamp
48
49 clean:
50         dh_testdir
51         dh_testroot
52         if [ -e Makefile ]; then $(MAKE) -i distclean; fi
53         rm -f build-stamp configure-stamp
54         dh_clean 
55
56 .PHONY: binary binary-arch binary-indep install build configure clean