Debian lenny version packages
[pkg-perl] / deb-src / libhtml-parser-perl / libhtml-parser-perl-3.56 / debian / rules
1 #!/usr/bin/make -f
2
3 PERL=/usr/bin/perl
4
5 binary: binary-arch
6
7 binary-arch: build install
8         dh_testdir
9         dh_testroot
10         dh_installdocs TODO
11         chmod a+x eg/hform
12         dh_installexamples eg/hanchors eg/hform eg/hrefsub eg/hstrip eg/htext eg/htextsub eg/htitle
13         dh_installchangelogs Changes
14         dh_strip
15         dh_fixperms
16         dh_compress
17         dh_installdeb
18         dh_perl
19         dh_shlibdeps
20         dh_gencontrol
21         dh_md5sums
22         dh_builddeb
23
24 binary-indep: 
25
26 install: build
27         dh_testdir
28         dh_testroot
29         dh_installdirs
30         $(MAKE) install INSTALLDIRS=vendor PREFIX=$(CURDIR)/debian/libhtml-parser-perl/usr
31         rm -rf debian/libhtml-parser-perl/usr/share/perl5
32
33 build: configure-stamp build-stamp
34 build-stamp:
35         dh_testdir
36         $(MAKE) OPTIMIZE="-O2 -g -Wall"
37         $(MAKE) test
38         touch build-stamp
39
40 configure: configure-stamp
41 configure-stamp:
42         dh_testdir
43         $(PERL) Makefile.PL INSTALLDIRS=vendor
44         touch configure-stamp
45
46 clean:
47         dh_testdir
48         dh_testroot
49         if [ -e Makefile ]; then $(MAKE) -i distclean; fi
50         rm -f build-stamp configure-stamp
51         dh_clean 
52
53 .PHONY: binary binary-arch binary-indep install build configure clean