Added correct PATH and SBOX_REDIRECT_IGNORE and PERL5LIB envs in rules for libfilter...
[pkg-perl] / deb-src / libfilter-perl / libfilter-perl-1.34 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
9 unexport PERL5LIB
10 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
11
12 tmp        = $(CURDIR)/debian/libfilter-perl
13 config     = INSTALLDIRS=vendor INSTALLMAN3DIR=/usr/share/man/man3
14 vendorarch = `perl -MConfig -e 'print $$Config{vendorarch}'`
15
16 configure: configure-stamp
17 configure-stamp:
18         dh_testdir
19         # Add here commands to configure the package.
20         perl Makefile.PL $(config)
21
22         touch configure-stamp
23
24 build: configure build-stamp
25 build-stamp:
26         dh_testdir
27
28         # Add here commands to compile the package.
29 ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
30         $(MAKE) OPTIMIZE="-O2 -g -Wall"
31 else
32         $(MAKE) OPTIMIZE="-g -Wall"
33 endif
34
35         touch build-stamp
36
37 clean: configure
38         dh_testdir
39         dh_testroot
40
41         # Add here commands to clean up after the build process.
42         [ ! -f Makefile ] || $(MAKE) realclean
43         rm -f Try.pm    # for 'make test'
44
45         dh_clean build-stamp configure-stamp
46
47 install: build
48         dh_testdir
49         dh_testroot
50         dh_clean -k
51         dh_installdirs
52
53         # Add here commands to install the package into debian/tmp.
54         $(MAKE) install PREFIX=$(tmp)/usr
55
56 # Build architecture-independent files here.
57 binary-indep: build install
58 # We have nothing to do by default.
59
60 # Build architecture-dependent files here.
61 binary-arch: build install
62         dh_testdir
63         dh_testroot
64         dh_installdocs
65         dh_installexamples
66         dh_installchangelogs Changes
67         dh_strip
68         dh_compress
69         dh_fixperms
70         dh_installdeb
71         dh_perl
72         dh_shlibdeps
73         dh_gencontrol
74         dh_md5sums
75         dh_builddeb
76
77 binary: binary-indep binary-arch
78 .PHONY: build clean binary-indep binary-arch binary install configure