Added correct PATH and SBOX_REDIRECT_IGNORE and PERL5LIB envs in rules for dh-make...
[pkg-perl] / deb-src / dh-make-perl / dh-make-perl-0.47 / debian / rules
1 #!/usr/bin/make -f
2 #-*- makefile -*-
3 # Made with the aid of dh_make, by Craig Small
4 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5 # Some lines taken from debmake, by Christoph Lameter.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
10 unexport PERL5LIB
11 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
12
13 INST=$(CURDIR)/debian/dh-make-perl
14
15 build: build-stamp
16 build-stamp:
17         dh_testdir
18
19         # Add here commands to compile the package.
20         pod2man --center debian dh-make-perl > dh-make-perl.1
21
22         touch build-stamp
23
24 clean:
25         dh_testdir
26         dh_testroot
27         rm -f build-stamp
28
29         # Add here commands to clean up after the build process.
30         @for i in Strange-0.1 Strange-2.1; do\
31                 if test -d "$$i/debian"; then \
32                         cd $$i; \
33                         debian/rules clean; \
34                         cd ..; \
35                         rm -rf $$i/debian; \
36                 fi \
37         done
38
39         dh_clean dh-make-perl.1 $(wildcard *.changes) $(wildcard *.deb) $(wildcard *.gz)
40
41 install:
42         dh_testdir
43         dh_testroot
44         dh_clean -k
45         dh_installdirs
46
47         # Add here commands to install the package into debian/tmp.
48         #$(MAKE) install DESTDIR=`pwd`/debian/tmp
49         mkdir -p $(INST)/usr/bin
50         mkdir -p $(INST)/usr/share/dh-make-perl
51         cp dh-make-perl $(INST)/usr/bin
52         cp rules* $(INST)/usr/share/dh-make-perl
53         cp overrides $(INST)/usr/share/dh-make-perl
54
55
56 # Build architecture-independent files here.
57 binary-arch: build install
58 # We have nothing to do by default.
59
60 # Build architecture-dependent files here.
61 binary-indep: build install
62         dh_testdir
63         dh_testroot
64         dh_installdocs README
65         dh_installman dh-make-perl.1
66         dh_installchangelogs
67         dh_compress
68         dh_fixperms
69         dh_installdeb
70         dh_perl 
71         dh_gencontrol
72         dh_md5sums
73         dh_builddeb
74
75 source diff:
76         @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
77
78 binary: binary-indep binary-arch
79 .PHONY: build clean binary-indep binary-arch binary