Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / sapwood_3.1.1.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Sapwood: pixbuf based theming for gtk+ 2.x"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.0"
7 SECTION = "x11/base"
8 DEPENDS = "gtk+ upstart"
9
10 PR = "r2"
11
12 SRC_URI = "http://repository.maemo.org/pool/maemo5.0beta/free/s/${PN}/${PN}_${PV}-2+0m5.tar.gz \
13            file://sapwood/mer-changes.patch;patch=1 \
14            file://sapwood/socket.patch;patch=1;pnum=0 "
15
16 inherit autotools pkgconfig
17
18 EXTRA_OECONF += "--enable-abstract-sockets=no"
19
20
21 FILES_${PN} += "${libdir}/gtk-2.0/2.10.0/engines/"
22
23 do_stage(){
24     autotools_stage_all
25 }
26
27
28 do_install_append () {
29         install -d ${D}${sysconfdir}/osso-af-init ${D}${sysconfdir}/X11/replace/Xsession.d/
30         install -m 755 ${S}/debian/sapwood-server.sh  ${D}${sysconfdir}/osso-af-init/sapwood-server.sh
31     install -m 755 ${S}/debian/gtk2-engines-sapwood.xsession ${D}${sysconfdir}/X11/replace/Xsession.d/gtk2-engines-sapwood
32
33 }
34