Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / libdb1_1.85.4.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Berkeley database library"
5 HOMEPAGE = "unknown"
6 LICENSE = "UCB BSD license"
7 SECTION = "libs"
8 PR = "r0"
9
10 SRC_URI = "http://repository.maemo.org/pool/maemo5.0beta/free/libd/${PN}/${PN}_${PV}-osso8.tar.gz \
11            file://libdb1/makefile.patch;patch=1;pnum=0 "
12
13
14 S = "${WORKDIR}/${PN}-${PV}/PORT/linux"
15
16
17 do_compile() {
18         oe_runmake PREFIX=${prefix} libdir=${libdir} includedir=${includedir} D=${D} 
19 }
20
21
22 do_install() {
23         oe_runmake PREFIX=${prefix}  libdir=${libdir} includedir=${includedir} D=${D} DESTDIR=${D} install
24 }
25
26 #FIXME Check if there is a better way to do this
27 do_stage(){
28     install -d ${STAGING_INCDIR}/db 
29         install    -m 644 libdb.a ${STAGING_LIBDIR}
30         install    -m 644 libdb.so.1.85.4 ${STAGING_LIBDIR}
31     ln -s ${STAGING_LIBDIR}/libdb.so.1.85.4 ${STAGING_LIBDIR}/libdb1.so 
32     install -m 644 include/mpool.h ${STAGING_INCDIR}/db/mpool.h
33         install -m 644 include/db.h ${STAGING_INCDIR}/db/db.h
34 }
35