Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / hildon-desktop_2.0.19.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Desktop env. based on the GNOME platform"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "x11"
8 DEPENDS = " libhildon libosso osso-gnome-vfs2 osso-af-settings libhildonfm libhildonhelp libxtst libxi libxml2 esound libxdamage sqlite3 mce-dev"
9 PR = "r1"
10
11 ##Temporary: to be fixed later
12 SRC_URI = "file://hd-trial.tar.gz"
13
14 EXTRA_OECONF = "--enable-debug=yes --disable-gtk-doc"
15
16 S = "${WORKDIR}/hd-ins_in_usr"
17
18 inherit autotools pkgconfig
19
20 FILES_${PN} += "${datadir}/applications/hildon-marquee/* \ 
21                 ${datadir}/* "
22
23
24 do_install_append(){
25     install -d ${D}${datadir}/applications ${D}${datadir}/applications/hildon-marquee
26     install -m 0644 ${S}/data/*.desktop  ${D}${datadir}/applications/hildon-marquee
27 }
28
29
30
31
32 do_stage(){
33     autotools_stage_all
34 }
35
36 # Avoid rm_work for the meanwhile
37 # to check image contents 
38 do_rm_work(){
39     :
40 }