Made a whole lot of changes to gtk+ recipes to get rid of the standalone gdk-pixbuf...
[oespirit1] / gtk+ / gtk+_2.12.12.bb
1 # 01/06/09 15:33:17  Kirtika B Ruchandani <kirtibr@gmail.com> 
2 # Temporary recipe for Maemo GTK for testing 
3 # Copied over from the 2.12.11 bb file and modified
4
5 require gtk+.inc
6
7 # Temporary additions for testing
8 # to get rid of the vagaries of the 
9 # standalone gdk-pixbuf recipe
10 PROVIDES = "gdk-pixbuf"
11 RPROVIDES = "gdk-pixbuf"
12 EXTRA_OECONF += "--with-included-loaders=png,tga --disable-gtk-doc"
13
14 PR = "r103"
15
16 DEPENDS += "cairo"
17
18 DEFAULT_PREFERENCE = 1
19
20 S="${WORKDIR}/gtk+2.0-2.12.12"
21
22 #FIXME : Patches currently used are only to get the build working. 
23 #        After testing on the device,
24 #        uncomment the required patches
25
26 SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${PV}-1maemo12+0m5.tar.gz \
27            file://gtk+2.0-2.12.12/mer-changes.patch;patch=1 \
28            file://gtk+2.0-2.12.12/mkinstalldirs \
29            file://gtk+2.0-2.12.12/no-demos.patch;patch=1 \
30            file://gtk+2.0-2.12.12/xsettings.patch;patch=1 \
31 #          file://gtk+2.0-2.12.12/run-iconcache.patch;patch=1 \
32 #          file://gtk+2.0-2.12.12/hardcoded_libtool.patch;patch=1 \
33            file://gtk+2.0-2.12.12/cellrenderer-cairo.patch;patch=1;pnum=0 \
34 #this one really needs to be killed
35            file://gtk+2.0-2.12.12/png-use-old-symbol.patch;patch=1;pnum=0 \
36            file://gtk+2.0-2.12.12/entry-cairo.patch;patch=1;pnum=0 "
37 #           file://gtk+2.0-2.12.12/toggle-font.diff;patch=1;pnum=0 \
38 #           file://gtk+2.0-2.12.12/scrolled-placement.patch;patch=1;pnum=0 \
39 # temporary
40 #           file://gtk+2.0-2.12.12/gtklabel-resize-patch;patch=1 \
41 #           file://gtk+2.0-2.12.12/menu-deactivate.patch;patch=1 \
42 #           file://gtk+2.0-2.12.12/combo-arrow-size.patch;patch=1;pnum=0 \
43 # die die die
44 #           file://gtk+2.0-2.12.12/pangoxft2.10.6.diff;patch=1"
45
46 EXTRA_OECONF = "--with-libtiff --with-gdktarget=x11 --disable-xkb --enable-display-migration --disable-gtk-doc --with-maemo=yes --with-libpng --with-libjpeg --with-x "
47
48
49
50
51 LIBV = "2.10.0"
52
53 PACKAGES_DYNAMIC = "gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
54
55 do_configure_prepend(){
56     touch gtk-doc.make
57 }
58
59 python populate_packages_prepend () {
60         import os.path
61
62         prologue = bb.data.getVar("postinst_prologue", d, 1)
63
64         gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
65         loaders_root = os.path.join(gtk_libdir, 'loaders')
66         immodules_root = os.path.join(gtk_libdir, 'immodules')
67         printmodules_root = os.path.join(gtk_libdir, 'printbackends');
68
69         do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', prologue + 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
70         do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules')
71         do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
72
73         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
74                 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
75 }
76
77 PACKAGES += "gdk-pixbuf"
78
79 FILES_gdk-pixbuf = " ${bindir}/gdk-pixbuf-query-loaders \
80                          ${bindir}/gtk-update-icon-cache \
81                          ${libdir}/libgdk*"
82
83 # check for TARGET_FPU=soft and inform configure of the result 
84 # so it can disable some floating points
85 require gtk-fpu.inc
86 EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
87
88
89