Added glib recipe -the *native* bb files have been taken directly from OE and added...
[oespirit1] / glib-2.0 / glib-2.0-native_2.4.6.bb
1 DESCRIPTION = "GLib is a general-purpose utility library, \
2 which provides many useful data types, macros, \
3 type conversions, string utilities, file utilities, a main \
4 loop abstraction, and so on. It works on many \
5 UNIX-like platforms, Windows, OS/2 and BeOS."
6 LICENSE = "LGPL"
7 SECTION = "libs"
8 PRIORITY = "optional"
9 DEPENDS = "gtk-doc-native"
10 PR = "r6"
11
12 EXTRA_OECONF = "--disable-debug"
13
14 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.4/glib-${PV}.tar.bz2 \
15            file://visibility.patch;patch=1 \
16            file://glibconfig-sysdefs.h \
17            file://configure-libtool.patch;patch=1"
18
19 S = "${WORKDIR}/glib-${PV}"
20
21 inherit autotools pkgconfig native gettext
22
23 acpaths = ""
24 do_configure_prepend () {
25         install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
26 }
27
28 do_stage () {
29         install -m 0755 gobject/glib-mkenums ${STAGING_BINDIR}/
30         install -m 0755 gobject/.libs/glib-genmarshal ${STAGING_BINDIR}/
31         install -m 0755 glib-gettextize ${STAGING_BINDIR}/
32         oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
33         oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
34         oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
35         oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
36         autotools_stage_includes
37         install -d ${STAGING_INCDIR}/glib-2.0/glib
38         install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
39         install -d ${STAGING_DATADIR}/aclocal
40         install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
41         install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
42         install -d ${STAGING_DATADIR}/glib-2.0/gettext/po
43         install -m 0755 mkinstalldirs ${STAGING_DATADIR}/glib-2.0/gettext/
44         install -m 0644 po/Makefile.in.in ${STAGING_DATADIR}/glib-2.0/gettext/po/
45 }
46
47 do_install () {
48         :
49 }