Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / clipboard-manager_0.6.8.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Clipboard Manager"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "unknown"
7 SECTION = "x11"
8 DEPENDS = "libx11 gconf glib-2.0 upstart"
9 PR = "r4"
10
11 SRC_URI = "http://repository.maemo.org/pool/maemo5.0beta/free/c/${PN}/${PN}_${PV}-4+0m5.tar.gz"
12
13 inherit autotools pkgconfig
14
15 do_install_append(){
16     install -d ${D}${sysconfdir}/X11 ${D}${sysconfdir}/gconf2xsettings.d
17     install -d ${D}${sysconfdir}/X11/replace/Xsession.post
18     install -m 0644  ${S}/keys ${D}${sysconfdir}/gconf2xsettings.d
19     install -m 0755  ${S}/debian/clipboard-manager.xsession ${D}${sysconfdir}/X11/replace/Xsession.post
20 }