Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / alarmd_0.5.20.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Cron like daemon functionality"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "base"
8 DEPENDS = "dbus dbus-glib glib-2.0 libconic osso-systemui-dbus-dev mce-dev "
9 PR = "r0"
10
11 SRC_URI = "http://repository.maemo.org/pool/diablo/free/a/${PN}/${PN}_${PV}.tar.gz  \
12            file://alarmd-patches/mer-changes.patch;patch=1"
13
14 # A test workaround to fix the "No GNU_HASH"
15 # in elf binary issue            
16 TARGET_CC_ARCH += "${LDFLAGS}"
17
18
19 inherit autotools pkgconfig
20
21 PARALLEL_MAKE = ""
22 EXTRA_OEMAKE = "LIBTOOL=arm-${DISTRO}-linux-gnueabi-libtool"
23
24
25
26
27 do_configure_prepend(){
28     for i in `grep -l -r Werror *`;
29         do sed -i s:-Werror::g $i;
30     done
31 }
32
33
34 # FIXME Ugly hack follows
35 # Need to know why that file is created with
36 # 0 value for permisions
37 do_install_prepend(){
38     chmod --recursive 777 ${S}/.pc
39 }
40
41
42
43 do_install(){
44     install -d ${D}${bindir} ${D}${libdir} ${D}${includedir}  ${D}${libdir}/alarmd
45     install -m 0755 ${S}/.libs/alarmd ${D}${bindir}
46     install -m 0755 ${S}/.libs/alarmtool ${D}${bindir}
47     install -m 0755 ${S}/.libs/apitest ${D}${bindir}
48     install -m 0755 ${S}/.libs/dbustest ${D}${bindir}
49     oe_libinstall -so libalarm ${D}${libdir}
50     oe_libinstall -so libretu ${D}${libdir}/alarmd
51     oe_libinstall -so libgtimeout ${D}${libdir}/alarmd
52     install -m 0644 ${S}/include/*.h ${D}${includedir}
53 }
54
55 do_stage(){
56     install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}   
57     oe_libinstall -so libalarm    ${STAGING_LIBDIR}
58     oe_libinstall -so libretu     ${STAGING_LIBDIR}
59     oe_libinstall -so libgtimeout ${STAGING_LIBDIR}
60     install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}
61 }
62
63 PACKAGES += " alarmtool libalarm0"
64
65 #Keeping in tune with Maemo packaging
66 FILES_${PN} += "${libdir}/libretu.so \ 
67                 ${libdir}/libgtimeout.so"
68 FILES_alarmtool = "${bindir}/alarmtool"
69
70 FILES_libalarm  = "${libdir}/libalarm.so.*"
71
72