Install public transport map.
[marble] / packaging / debian / patches / newstuff-mapthemes.diff
1 Index: src-fremantle/data/CMakeLists.txt
2 ===================================================================
3 --- src-fremantle.orig/data/CMakeLists.txt      2012-02-19 11:51:05.000000000 +0100
4 +++ src-fremantle/data/CMakeLists.txt   2012-02-19 11:55:20.000000000 +0100
5 @@ -145,6 +145,113 @@
6  DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/hillshading/0/0)
7  
8  install (FILES
9 +maps/earth/osmarender/osmarender.dgml
10 +maps/earth/osmarender/osmarender-preview.png
11 +maps/earth/osmarender/legend.html
12 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/osmarender)
13 +
14 +install (FILES
15 +maps/earth/osmarender/legend/airportapron.png
16 +maps/earth/osmarender/legend/airportrunway.png
17 +maps/earth/osmarender/legend/allotments.png
18 +maps/earth/osmarender/legend/boundary.png
19 +maps/earth/osmarender/legend/bridge.png
20 +maps/earth/osmarender/legend/bridleway.png
21 +maps/earth/osmarender/legend/byway.png
22 +maps/earth/osmarender/legend/cemetery.png
23 +maps/earth/osmarender/legend/commercial.png
24 +maps/earth/osmarender/legend/cycleway.png
25 +maps/earth/osmarender/legend/farm.png
26 +maps/earth/osmarender/legend/footway.png
27 +maps/earth/osmarender/legend/golfcourse.png
28 +maps/earth/osmarender/legend/meadow.png
29 +maps/earth/osmarender/legend/military.png
30 +maps/earth/osmarender/legend/motorway.png
31 +maps/earth/osmarender/legend/nationalreserve.png
32 +maps/earth/osmarender/legend/naturereserve.png
33 +maps/earth/osmarender/legend/pathway.png
34 +maps/earth/osmarender/legend/primaryroad.png
35 +maps/earth/osmarender/legend/quarry.png
36 +maps/earth/osmarender/legend/railway.png
37 +maps/earth/osmarender/legend/railwaystation.png
38 +maps/earth/osmarender/legend/retail.png
39 +maps/earth/osmarender/legend/secondaryroad.png
40 +maps/earth/osmarender/legend/significantbuilding.png
41 +maps/earth/osmarender/legend/sportcentre.png
42 +maps/earth/osmarender/legend/sportpitch.png
43 +maps/earth/osmarender/legend/station.png
44 +maps/earth/osmarender/legend/subway.png
45 +maps/earth/osmarender/legend/summitpeak.png
46 +maps/earth/osmarender/legend/track.png
47 +maps/earth/osmarender/legend/tram.png
48 +maps/earth/osmarender/legend/trunkroad.png
49 +maps/earth/osmarender/legend/tunnel.png
50 +maps/earth/osmarender/legend/unclassifiedroad.png
51 +maps/earth/osmarender/legend/unsurfacedroad.png
52 +maps/earth/osmarender/legend/wood.png
53 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/osmarender/legend)
54 +
55 +install (FILES
56 +maps/earth/osmarender/0/0/0.png
57 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/osmarender/0/0)
58 +
59 +install (FILES
60 +maps/earth/public-transport/public-transport.png
61 +maps/earth/public-transport/legend.html
62 +maps/earth/public-transport/public-transport.dgml
63 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/public-transport)
64 +
65 +install (FILES
66 +maps/earth/public-transport/legend/train_station.png
67 +maps/earth/public-transport/legend/subway_station.png
68 +maps/earth/public-transport/legend/light_rail_station.png
69 +maps/earth/public-transport/legend/bus_stop.png
70 +maps/earth/public-transport/legend/tram_station.png
71 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/public-transport/legend)
72 +
73 +install (FILES
74 +maps/earth/public-transport/0/0/0.png
75 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/public-transport/0/0)
76 +
77 +install (FILES
78 +maps/earth/hikebikemap/hikebikemap.dgml
79 +maps/earth/hikebikemap/hikebikemap-preview.png
80 +maps/earth/hikebikemap/legend.html
81 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/hikebikemap)
82 +
83 +install (FILES
84 +maps/earth/hikebikemap/legend/access_no.png
85 +maps/earth/hikebikemap/legend/bridleway.png
86 +maps/earth/hikebikemap/legend/cycleway.png
87 +maps/earth/hikebikemap/legend/farmland.png
88 +maps/earth/hikebikemap/legend/footway.png
89 +maps/earth/hikebikemap/legend/meadow_stream.png
90 +maps/earth/hikebikemap/legend/motorway.png
91 +maps/earth/hikebikemap/legend/parking_building.png
92 +maps/earth/hikebikemap/legend/path.png
93 +maps/earth/hikebikemap/legend/power_tower_line.png
94 +maps/earth/hikebikemap/legend/primary.png
95 +maps/earth/hikebikemap/legend/rail.png
96 +maps/earth/hikebikemap/legend/residential.png
97 +maps/earth/hikebikemap/legend/secondary.png
98 +maps/earth/hikebikemap/legend/tertiary.png
99 +maps/earth/hikebikemap/legend/track1.png
100 +maps/earth/hikebikemap/legend/track2.png
101 +maps/earth/hikebikemap/legend/track3.png
102 +maps/earth/hikebikemap/legend/track4.png
103 +maps/earth/hikebikemap/legend/track5.png
104 +maps/earth/hikebikemap/legend/water_allotments.png
105 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/hikebikemap/legend)
106 +
107 +install (FILES
108 +maps/earth/hikebikemap/0/0/0.png
109 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/hikebikemap/0/0)
110 +
111 +install (FILES
112 +maps/earth/hikebikemap/lighting/0/0/0.png
113 +DESTINATION ${MARBLE_DATA_INSTALL_PATH}/maps/earth/hikebikemap/lighting/0/0)
114 +
115 +install (FILES
116  maps/earth/temp-july/temp-july.jpg
117  maps/earth/temp-july/temp-july-preview.png
118  maps/earth/temp-july/temp-july.dgml