Refresh range check patch
[marble] / packaging / debian / patches / globe-projection-rangecheck.diff
1 Index: tmp.BqMy4aY8YI/src/lib/ScanlineTextureMapperContext.cpp
2 ===================================================================
3 --- tmp.BqMy4aY8YI.orig/src/lib/ScanlineTextureMapperContext.cpp        2011-06-07 22:40:08.000000000 +0200
4 +++ tmp.BqMy4aY8YI/src/lib/ScanlineTextureMapperContext.cpp     2011-06-07 22:40:18.000000000 +0200
5 @@ -176,8 +176,8 @@
6                      nextTile( posX, posY );
7                      itLon = prevPixelX + m_toTileCoordinatesLon;
8                      itLat = prevPixelY + m_toTileCoordinatesLat;
9 -                    posX = itLon + itStepLon * j;
10 -                    posY = itLat + itStepLat * j;
11 +                    posX = qMax<qreal>( 0.0, qMin<qreal>( tileWidth-1.0, itLon + itStepLon * j ) );
12 +                    posY = qMax<qreal>( 0.0, qMin<qreal>( tileHeight-1.0, itLat + itStepLat * j ) );
13                      oldPosX = -1;
14                  }
15