666bed5d9a936dd1144d6517f90a0b67521474ea
[marble] / packaging / debian / marble.postinst
1 #!/bin/sh
2
3 set -e
4
5 if [ "$1" != "configure" ]
6 then
7   exit 0
8 fi
9
10 ### Change old default values to new default values
11
12 CONFIG_FILE="/home/user/.config/kde.org/Marble Desktop Globe.conf"
13 if test -e "${CONFIG_FILE}"
14 then
15   sed -i \
16   -e 's/^sideBar=true$/sideBar=false/' \
17   -e 's/^volatileTileCacheLimit=30$/volatileTileCacheLimit=6/' \
18   -e 's/^projection=0$/projection=2/' \
19   -e '/^distanceUnit=/d' \
20   -e 's/^persistentTileCacheLimit=300$/persistentTileCacheLimit=0/' \
21   "${CONFIG_FILE}"
22   chown user:users "${CONFIG_FILE}"
23 fi
24
25 ### Migrate cached openstreetmap tiles to shared directory
26
27 # The OSM tile download location in Marble 1.0.x and earlier
28 OSM_DIR_10="/home/user/MyDocs/.local/share/marble/maps/earth/openstreetmap"
29
30 # The OSM tile download location in Marble 1.1 and later
31 OSM_DIR_11="/home/user/MyDocs/.maps/OpenStreetMap I"
32
33 # The OSM theme .dgml file
34 OSM_DGML="/opt/marble/share/marble/data/maps/earth/openstreetmap/openstreetmap.dgml"
35
36 # A file used as a flag to indicate a previous migration
37 MIGRATED="${OSM_DIR_10}/.migrated"
38
39 # Verify we have the .dgml file and can write to it (required)
40 test -w "${OSM_DGML}" || { echo "DGML file ${OSM_DGML} not existant/writable."; exit 1; }
41
42 # Check whether the tiles were previously migrated. In that case there's nothing to do
43 test -e "${MIGRATED}" && exit 0
44
45 # If the migration has to move files, ask the user to skip it since it can
46 # take some minutes to finish
47
48 test -e "${OSM_DIR_10}" && test -e "${OSM_DIR_11}" && { maemo-confirm-text "Enable OpenStreetMap Data Sharing" /opt/marble/share/marble/data/migration-warning.txt || exit 0; }
49
50 # Tile migration
51 mkdir -p "${OSM_DIR_11}"
52 if test -d "${OSM_DIR_10}"
53 then
54     # Cached tiles from an old Marble installation exist and must be migrated
55     for x in ${OSM_DIR_10}/[0-9]*
56     do
57         test -e "${x}" || continue
58         dx="$(basename ${x})"
59         if test -e "${OSM_DIR_11}/${dx}"
60         then
61             # Tiles /x/ were downloaded both in Marble and another application
62             for y in ${x}/[0-9]*
63             do
64                 test -e "${y}" || continue
65                 dy="$(basename ${y})"
66                 target="${OSM_DIR_11}/${dx}/${dy}/"
67                 if test -e "${target}"
68                 then
69                     # Tiles /x/y/ were downloaded both in Marble and another application. Move each /x/y/z
70                     mv "${y}"/[0-9]*.png "${target}"
71                     rmdir "${y}" || true
72                 else
73                     # Target dir does not exist yet, so we can move it over (much quicker)
74                     mv "${y}" "${OSM_DIR_11}/${dx}"
75                 fi
76             done
77             rmdir "${x}" || true
78         else
79             # Target does not exist yet, so we can move it over (much quicker)
80             mv "${x}" "${OSM_DIR_11}/"
81         fi
82     done
83 fi
84
85 # Delete now empty directory
86 test -d "${OSM_DIR_10}/" && rmdir "${OSM_DIR_10}/" || true
87
88 # If files are left in the old directory, leave a flag to avoid running 
89 # the migration again. This only happens if the user created custom files in
90 # the OSM cache directory
91 test -d "${OSM_DIR_10}/" && touch "${MIGRATED}"
92
93 # Finally, change the download location in the .dgml file. Also needed for new installations
94 sed -i "s@<sourcedir format=\"PNG\"> earth/openstreetmap </sourcedir>@<sourcedir format=\"PNG\"> ${OSM_DIR_11} </sourcedir>@" "${OSM_DGML}"
95
96 exit 0