evas: initial commit
[maemo-efl] / trunk / eet / debian / rules
1 #!/usr/bin/make -f
2 # Rewrote debian/rules to use cdbs.
3
4 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
5
6 include /usr/share/cdbs/1/rules/debhelper.mk
7 include /usr/share/cdbs/1/class/autotools.mk
8
9 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
10         DEB_CONFIGURE_SCRIPT_ENV += CFLAGS="$(CFLAGS) -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant"
11 endif
12         
13