95d2c4d04986ca5307ad5230c3baf219dd6b84b4
[maemo-efl] / trunk / ecore / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5 include /usr/share/cdbs/1/rules/simple-patchsys.mk
6
7 DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16        \
8                                                           --disable-ecore-fb                    \
9                                                           --disable-ecore-directfb              \
10                                                           --disable-ecore-evas-gl               \
11                                                           --disable-ecore-evas-dfb              \
12                                                           --disable-ecore-evas-xrender  \
13                                                           --disable-ecore-evas-fb               \
14                                                           --disable-ecore-sdl                   \
15                                                           --disable-ecore-evas-sdl
16
17 DEB_CONFIGURE_SCRIPT_ENV += CURL_LIBS="-lcurl"
18
19 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
20
21 CFLAGS += -I/usr/X11R6/include
22
23 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
24         CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
25         ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
26                 CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
27         endif
28         ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
29                 CFLAGS += -mcpu=arm926ej-s
30         endif
31 endif
32