Added some code to peer into a data structure in Maemian/Schedule.pm. Also added the
[maemian] / nokia-lintian / testset / non-us / debian / rules
1 #!/usr/bin/make -f
2
3 PATENT=patented-app
4 CRYPTO=crypto-app
5 BROKEN=broken-crypto
6 NONFREE=nonfree-crypto-app
7
8 build:
9
10 binary-arch:
11
12 binary-indep:
13         # patented-app
14         install -d debian/$(PATENT)-tmp/DEBIAN
15         install -d debian/$(PATENT)-tmp/usr/share/doc/$(PATENT)
16         gzip -9c debian/changelog > debian/$(PATENT)-tmp/usr/share/doc/$(PATENT)/changelog.gz
17         dpkg-gencontrol -isp -p$(PATENT) -Pdebian/$(PATENT)-tmp
18         dpkg --build debian/$(PATENT)-tmp ..
19
20         # crypto-app
21         install -d debian/$(CRYPTO)-tmp/DEBIAN
22         install -d debian/$(CRYPTO)-tmp/usr/share/doc/$(CRYPTO)
23         echo '© 2000' > debian/$(CRYPTO)-tmp/usr/share/doc/$(CRYPTO)/copyright
24         dpkg-gencontrol -isp -p$(CRYPTO) -Pdebian/$(CRYPTO)-tmp
25         dpkg --build debian/$(CRYPTO)-tmp ..
26
27         # broken-crypto
28         install -d debian/$(BROKEN)-tmp/DEBIAN
29         dpkg-gencontrol -isp -p$(BROKEN) -Pdebian/$(BROKEN)-tmp
30         dpkg --build debian/$(BROKEN)-tmp ..
31
32         # nonfree-crypto-app
33         install -d debian/$(NONFREE)-tmp/DEBIAN
34         dpkg-gencontrol -isp -p$(NONFREE) -Pdebian/$(NONFREE)-tmp
35         dpkg --build debian/$(NONFREE)-tmp ..
36
37 binary: binary-arch binary-indep
38
39 clean:
40
41 .PHONY: build binary-arch binary-indep binary clean