Adding side stream changes to Maemian. Working to integrate full upstream libraries...
[maemian] / nokia-lintian / testset / binary / debian / rules
1 #!/usr/bin/make -f
2
3 tmp=debian/tmp
4
5 # This reference to $(PWD) should not cause an error but the one below
6 # should.
7 build:
8         make
9         echo $(PWD)
10
11 clean:
12         make -i clean
13         rm -f debian/files debian/substvars
14
15 binary-arch: build
16         install -d $(tmp)/usr/bin
17         install -d $(tmp)/boot/hello
18         install -m 755 hello $(tmp)/usr/bin
19         touch $(tmp)/usr/bin/iminusrbin
20         chmod 755 $(tmp)/usr/bin/iminusrbin
21         install -m 755 hello-static $(tmp)/usr/bin
22         strip $(tmp)/usr/bin/hello-static
23         install -m 755 hello-static $(tmp)/usr/bin/hello.static
24         strip --remove-section=.comment --remove-section=.note $(tmp)/usr/bin/hello.static
25         ln $(tmp)/usr/bin/hello.static $(tmp)/usr/bin/static-hello
26         install -m 755 hello-static $(tmp)/boot/hello
27         strip --remove-section=.comment --remove-section=.note $(tmp)/boot/hello/hello-static
28         install -d $(tmp)/usr/share/doc/binary
29         install -m 644 INSTALL $(tmp)/usr/share/doc/binary
30         install -d $(tmp)/usr/share/doc/binary/html
31         echo '<html></html>' > $(tmp)/usr/share/doc/binary/html/index.html
32         echo '<html></html>' > $(tmp)/usr/share/doc/binary/html/ch1.html
33         ln -s ../html/./ch1.html $(tmp)/usr/share/doc/binary/html/ch2.html
34         ln -s /usr/share/doc/binary/htm/ch1.html $(tmp)/usr/share/doc/binary/html/ch3.html
35         echo '<html></html>' > $(tmp)/usr/share/doc/binary/html/ch5.html
36         ln $(tmp)/usr/share/doc/binary/html/ch5.html \
37             $(tmp)/usr/share/doc/binary/html/ch6.html
38         install -d $(tmp)/usr/share/menu
39         install -d $(tmp)/usr/lib/menu
40         install -d $(tmp)/usr/share/binary
41         install -m 644 debian/menu $(tmp)/usr/share/menu/binary
42         install -m 644 debian/menu $(tmp)/usr/lib/menu/binary
43         install -d $(tmp)/etc/menu-methods
44         install -m 755 debian/menu-method $(tmp)/etc/menu-methods/lintian
45         install -d $(tmp)/usr/share/doc-base
46         install -m 644 debian/doc-base $(tmp)/usr/share/doc-base/binary
47         touch '$(tmp)/usr/share/doc-base/space '
48         install -m 644 debian/README.Debian $(tmp)/usr/share/doc/binary
49         install -m 644 debian/NEWS.Debian $(tmp)/usr/share/doc/binary
50         gzip -9 $(tmp)/usr/share/doc/binary/NEWS.Debian
51         install -m 644 debian/copyright $(tmp)/usr/share/doc/binary
52         install -m 644 debian/changelog $(tmp)/usr/share/doc/binary
53         #gzip -9 $(tmp)/usr/share/doc/binary/changelog
54         install -d $(tmp)/DEBIAN
55         install -m 755 debian/postinst $(tmp)/DEBIAN
56         install -m 644 debian/conffiles $(tmp)/DEBIAN
57
58         install -d $(tmp)/usr/share/applications
59         install -m 644 debian/hello.desktop \
60             $(tmp)/usr/share/applications/hello.desktop
61         install -m 755 debian/goodbye.desktop \
62             $(tmp)/usr/share/applications/goodbye.desktop
63
64         # should be ok...
65         echo boe > $(tmp)/usr/bar
66         ln $(tmp)/usr/bar $(tmp)/usr/foo 
67         # but this isn't
68         echo boe > $(tmp)/usr/bar2
69         ln $(tmp)/usr/bar2 $(tmp)/usr/share/baz 
70
71         dd if=/dev/zero of=$(tmp)/usr/share/binary/largefile bs=1024 count=2000
72
73         install -d debian/binary-data/DEBIAN
74         install -d debian/binary-data/usr/share/doc
75         ln -s binary debian/binary-data/usr/share/doc/binary-data
76
77         dpkg-shlibdeps $(tmp)/usr/bin/hello
78         dpkg-gencontrol -pbinary -isp
79         dpkg-gencontrol -pbinary-data -Pdebian/binary-data -isp
80
81         # Test an md5sums check while we're here.
82         touch debian/binary-data/DEBIAN/md5sums
83
84         dpkg --build debian/tmp ..
85         dpkg --build debian/binary-data ..
86
87 binary: binary-arch
88
89 .PHONY: build binary-arch binary clean