78a845fc473e257612330a621190f3ede83c2184
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / usbignpower.diff
1 --- kernel-power-2.6.28.orig/drivers/usb/core/generic.c
2 +++ kernel-power-2.6.28/drivers/usb/core/generic.c
3 @@ -97,10 +97,10 @@
4                  */
5  
6                 /* Rule out configs that draw too much bus current */
7 -               if (c->desc.bMaxPower * 2 > udev->bus_mA) {
8 +               /*if (c->desc.bMaxPower * 2 > udev->bus_mA) {
9                         insufficient_power++;
10                         continue;
11 -               }
12 +               }*/
13  
14                 /* When the first config's first interface is one of Microsoft's
15                  * pet nonstandard Ethernet-over-USB protocols, ignore it unless
16 @@ -132,10 +132,10 @@
17                         best = c;
18         }
19  
20 -       if (insufficient_power > 0)
21 +       /*if (insufficient_power > 0)
22                 dev_info(&udev->dev, "rejected %d configuration%s "
23                         "due to insufficient available bus power\n",
24 -                       insufficient_power, plural(insufficient_power));
25 +                       insufficient_power, plural(insufficient_power));*/
26  
27         if (best) {
28                 i = best->desc.bConfigurationValue;