1239e5b6a2936b45f7a5c51aab3917b091a5d199
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / usbhost3.diff
1 --- kernel-power-2.6.28.orig/drivers/usb/gadget/nokia.c
2 +++ kernel-power-2.6.28/drivers/usb/gadget/nokia.c
3 @@ -142,8 +142,7 @@
4         .bind           = nokia_bind_config,
5         .bConfigurationValue = 1,
6         /* .iConfiguration = DYNAMIC */
7 -       .bmAttributes   = USB_CONFIG_ATT_ONE,
8 -       .bMaxPower      = 250, /* 500mA */
9 +       .bmAttributes           = USB_CONFIG_ATT_SELFPOWER
10  };
11  
12  static struct usb_configuration nokia_config_100ma_driver = {
13 @@ -151,8 +150,7 @@
14         .bind           = nokia_bind_config,
15         .bConfigurationValue = 2,
16         /* .iConfiguration = DYNAMIC */
17 -       .bmAttributes   = USB_CONFIG_ATT_ONE | USB_CONFIG_ATT_SELFPOWER,
18 -       .bMaxPower      = 50, /* 100 mA */
19 +       .bmAttributes           = USB_CONFIG_ATT_SELFPOWER
20  };
21  
22  static int __init nokia_bind(struct usb_composite_dev *cdev)
23 --- kernel-power-2.6.28.orig/arch/arm/mach-omap2/Makefile
24 +++ kernel-power-2.6.28/arch/arm/mach-omap2/Makefile
25 @@ -100,7 +100,8 @@
26                                            board-rx51-peripherals.o \
27                                            mmc-twl4030.o \
28                                            ssi.o \
29 -                                          usb-musb.o
30 +                                          usb-ehci.o \
31 +                                          usb-musb.o 
32  obj-$(CONFIG_MACH_NOKIA_RX71)          += board-rx71.o \
33                                            board-rx71-peripherals.o
34