Changes to series and rx51_defconfig file for BFQ
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / reiser4-2.6.28.1-fix.patch
1 Adapt Reiser4 to changes introduced in 2.6.28.1
2 By Ingo Bormuth, Tue, 27 Jan 2009 11:02:01 +0100
3
4 Reference: http://www.spinics.net/lists/reiserfs-devel/msg01308.html
5 ---
6
7 --- linux-2.6.28.orig/fs/reiser4/plugin/file/file_conversion.c
8 +++ linux-2.6.28/fs/reiser4/plugin/file/file_conversion.c
9 @@ -686,7 +686,8 @@ int reiser4_write_begin_careful(struct f
10         start = pos & (PAGE_CACHE_SIZE - 1);
11         end = start + len;
12  
13 -       page = __grab_cache_page(mapping, index);
14 +       page = grab_cache_page_write_begin(mapping, index,
15 +                                          flags & AOP_FLAG_NOFS);
16         *pagep = page;
17         if (!page)
18                 return -ENOMEM;