Changes to series and rx51_defconfig file for BFQ
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / mm-zero_swappiness.patch
1 Yet to see a desktop workload that benefits from swappiness being higher than
2 zero. Make it so by default.
3
4 -ck
5
6 ---
7  mm/vmscan.c |    2 +-
8  1 file changed, 1 insertion(+), 1 deletion(-)
9
10 Index: linux-2.6.34-ck1/mm/vmscan.c
11 ===================================================================
12 --- linux-2.6.34-ck1.orig/mm/vmscan.c   2010-05-18 12:26:16.233444880 +1000
13 +++ linux-2.6.34-ck1/mm/vmscan.c        2010-05-18 12:26:16.371569589 +1000
14 @@ -126,7 +126,7 @@ struct scan_control {
15  /*
16   * From 0 .. 100.  Higher means more swappy.
17   */
18 -int vm_swappiness = 60;
19 +int vm_swappiness;
20  long vm_total_pages;   /* The total number of pages which the VM controls */
21  
22  static LIST_HEAD(shrinker_list);