Changes to series and rx51_defconfig file for BFQ
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / madde.patch
1 --- kernel-power-2.6.28/Makefile        2011-01-23 14:06:07.000000000 +0100
2 +++ kernel-power-2.6.28/Makefile        2011-01-23 14:06:53.000000000 +0100
3 @@ -4,6 +4,8 @@ SUBLEVEL = 28
4  EXTRAVERSION = .10power
5  NAME = Erotic Pickled Herring
6  
7 +export PATH := /usr/bin:$(HOME)/.madde/0.6.72/toolchains/arm-2007q3-51sb6-gdb701-arm-none-linux-gnueabi_linux/bin:$(PATH)
8 +
9  # *DOCUMENTATION*
10  # To see a list of typical targets execute "make help"
11  # More info can be located in ./README
12 @@ -196,7 +198,7 @@ SUBARCH := arm
13  # Note: Some architectures assign CROSS_COMPILE in their arch/*/Makefile
14  export KBUILD_BUILDHOST := $(SUBARCH)
15  ARCH           ?= $(SUBARCH)
16 -CROSS_COMPILE  ?= arm-linux-
17 +CROSS_COMPILE  ?= arm-none-linux-gnueabi-
18  
19  # Architecture as present in compile.h
20  UTS_MACHINE    := $(ARCH)
21 --- kernel-power-2.6.28/scripts/unifdef.c       2011-01-23 18:22:03.000000000 +0100
22 +++ kernel-power-2.6.28/scripts/unifdef.c       2011-01-23 18:22:17.000000000 +0100
23 @@ -206,6 +206,7 @@
24  static void             error(const char *);
25  static int              findsym(const char *);
26  static void             flushline(bool);
27 +#define getline _getline
28  static Linetype         getline(void);
29  static Linetype         ifeval(const char **);
30  static void             ignoreoff(void);