Changes to series and rx51_defconfig file for BFQ
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / cpufreq_earlyload.diff
1 From 30b1d92216154c9da2c9c33b6add9c458f98df44 Mon Sep 17 00:00:00 2001
2 From: Alistair Buxton <a.j.buxton@gmail.com>
3 Date: Wed, 8 Sep 2010 11:51:21 +0100
4 Subject: [PATCH] Fix CPU frequency driver so that it loads *before* the things that use it.
5
6 Signed-off-by: Alistair Buxton <a.j.buxton@gmail.com>
7 ---
8  arch/arm/plat-omap/cpu-omap.c |    2 +-
9  1 files changed, 1 insertions(+), 1 deletions(-)
10
11 diff --git a/arch/arm/plat-omap/cpu-omap.c b/arch/arm/plat-omap/cpu-omap.c
12 index 3974680..033a2bb 100644
13 --- a/arch/arm/plat-omap/cpu-omap.c
14 +++ b/arch/arm/plat-omap/cpu-omap.c
15 @@ -188,7 +188,7 @@ static int __init omap_cpufreq_init(void)
16         return cpufreq_register_driver(&omap_driver);
17  }
18  
19 -late_initcall(omap_cpufreq_init);
20 +arch_initcall(omap_cpufreq_init);
21  
22  /*
23   * if ever we want to remove this, upon cleanup call:
24 -- 
25 1.7.0.4