Several kernel patches by Con Kolivas to compliment BFS, adapted for 2.6.28
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / cpufreq-bfs_tweaks.patch
1 Because of the way BFS works it needs to transition up in frequency more
2 aggressively and down more conservatively.
3
4 -ck
5
6 ---
7  drivers/cpufreq/cpufreq_ondemand.c |   10 +++++-----
8  1 file changed, 5 insertions(+), 5 deletions(-)
9
10 Index: linux-2.6.34-ck1/drivers/cpufreq/cpufreq_ondemand.c
11 ===================================================================
12 --- linux-2.6.34-ck1.orig/drivers/cpufreq/cpufreq_ondemand.c    2010-02-25 21:51:48.000000000 +1100
13 +++ linux-2.6.34-ck1/drivers/cpufreq/cpufreq_ondemand.c 2010-05-18 12:26:18.124319654 +1000
14 @@ -28,10 +28,10 @@
15   * It helps to keep variable names smaller, simpler
16   */
17  
18 -#define DEF_FREQUENCY_DOWN_DIFFERENTIAL                (10)
19 -#define DEF_FREQUENCY_UP_THRESHOLD             (80)
20 +#define DEF_FREQUENCY_DOWN_DIFFERENTIAL                (17)
21 +#define DEF_FREQUENCY_UP_THRESHOLD             (63)
22  #define MICRO_FREQUENCY_DOWN_DIFFERENTIAL      (3)
23 -#define MICRO_FREQUENCY_UP_THRESHOLD           (95)
24 +#define MICRO_FREQUENCY_UP_THRESHOLD           (80)
25  #define MIN_FREQUENCY_UP_THRESHOLD             (11)
26  #define MAX_FREQUENCY_UP_THRESHOLD             (100)
27
28 @@ -455,10 +455,10 @@ static void dbs_check_cpu(struct cpu_dbs
29  
30         /*
31          * Every sampling_rate, we check, if current idle time is less
32 -        * than 20% (default), then we try to increase frequency
33 +        * than 37% (default), then we try to increase frequency
34          * Every sampling_rate, we look for a the lowest
35          * frequency which can sustain the load while keeping idle time over
36 -        * 30%. If such a frequency exist, we try to decrease to this frequency.
37 +        * 50%. If such a frequency exist, we try to decrease to this frequency.
38          *
39          * Any frequency increase takes it to the maximum frequency.
40          * Frequency reduction happens at minimum steps of
41