Clean up patch dir; synchronize patches with kernel-power v48
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / ck / mm-idleprio_prio-1.patch
1 Set the effective priority of idleprio tasks to that of nice 19 tasks when
2 modifying vm reclaim behaviour.
3
4 Signed-off-by: Con Kolivas <kernel@kolivas.org>
5
6  include/linux/sched.h |    2 +-
7  mm/vmscan.c           |    2 ++
8  2 files changed, 3 insertions(+), 1 deletion(-)
9
10 Index: linux-2.6.34-ck1/mm/vmscan.c
11 ===================================================================
12 --- linux-2.6.34-ck1.orig/mm/vmscan.c   2010-05-18 12:26:16.942194964 +1000
13 +++ linux-2.6.34-ck1/mm/vmscan.c        2010-05-18 12:26:17.090444482 +1000
14 @@ -1711,6 +1711,8 @@ static inline int effective_sc_prio(stru
15         if (likely(p->mm)) {
16                 if (rt_task(p))
17                         return -20;
18 +               if (p->policy == SCHED_IDLEPRIO)
19 +                       return 19;
20                 return task_nice(p);
21         }
22         return 0;
23 Index: linux-2.6.34-ck1/include/linux/sched.h
24 ===================================================================
25 --- linux-2.6.34-ck1.orig/include/linux/sched.h 2010-05-18 12:26:16.086194917 +1000
26 +++ linux-2.6.34-ck1/include/linux/sched.h      2010-05-18 12:26:17.091445870 +1000
27 @@ -38,9 +38,9 @@
28  #define SCHED_BATCH            3
29  /* SCHED_ISO: Implemented on BFS only */
30  #define SCHED_IDLE             5
31 +#define SCHED_IDLEPRIO         SCHED_IDLE
32  #ifdef CONFIG_SCHED_BFS
33  #define SCHED_ISO              4
34 -#define SCHED_IDLEPRIO         SCHED_IDLE
35  #define SCHED_MAX              (SCHED_IDLEPRIO)
36  #define SCHED_RANGE(policy)    ((policy) <= SCHED_MAX)
37  #endif
38