4374438658ebba5f1bd97db2c3f596971f3d9671
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / bq_matan.diff
1 --- kernel-maemo-2.6.28.orig/drivers/power/bq27x00_battery.c
2 +++ kernel-maemo-2.6.28/drivers/power/bq27x00_battery.c
3 @@ -358,6 +358,22 @@
4         .id_table = bq27200_id,
5  };
6  
7 +struct bq27200_platform_data {
8 +       int dummy;
9 +};
10 +
11 +static struct bq27200_platform_data bq27200_config = {
12 +       .dummy = 0,
13 +};
14 +
15 +static struct i2c_board_info rx51_camera_board_info_2 =
16 +       {
17 +               I2C_BOARD_INFO("bq27200", 0x55),
18 +               .platform_data = &bq27200_config,
19 +       };
20 +
21 +static struct i2c_client *client;
22 +
23  static int __init bq27x00_battery_init(void)
24  {
25         int ret;
26 @@ -365,6 +381,7 @@
27         ret = i2c_add_driver(&bq27200_battery_driver);
28         if (ret)
29                 printk(KERN_ERR "Unable to register BQ27200 driver\n");
30 +       client = i2c_new_device(i2c_get_adapter(2), &rx51_camera_board_info_2);
31  
32         return ret;
33  }